aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/cfortran/cfortran-4.4.ebuild')
-rw-r--r--dev-lang/cfortran/cfortran-4.4.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-lang/cfortran/cfortran-4.4.ebuild b/dev-lang/cfortran/cfortran-4.4.ebuild
deleted file mode 100644
index 2e9eb00fe..000000000
--- a/dev-lang/cfortran/cfortran-4.4.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit eutils
-
-DEB_PR="11"
-
-DESCRIPTION="Header file allowing to call Fortran routines from C and C++"
-SRC_URI="mirror://debian/pool/main/c/${PN}/${PN}_${PV}.orig.tar.gz
- mirror://debian/pool/main/c/${PN}/${PN}_${PV}-${DEB_PR}.diff.gz"
-HOMEPAGE="http://www-zeus.desy.de/~burow/cfortran/"
-KEYWORDS="~amd64 ~x86"
-LICENSE="LGPL-2"
-IUSE="examples"
-SLOT="0"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${WORKDIR}"/${PN}_${PV}-${DEB_PR}.diff
- if use examples; then
- unpack "${PN}".examples.tar.gz
- mv eg examples
- ln -sfn sz1.c examples/sz1/sz1.C
- ln -sfn pz.c examples/pz/pz.C
- fi
-}
-
-src_compile() {
- einfo "No compilation neccessary"
-}
-
-src_install() {
- insinto /usr/include/cfortran
- doins cfortran.h
- dosym /usr/include/cfortran/cfortran.h /usr/include/cfortran.h
- dodoc cfortran.doc debian/{NEWS,changelog,copyright}
- insinto /usr/share/doc/${PF}
- doins cfortran.html index.htm cfortest.c cfortex.f
- use examples && doins -r examples
-}