aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/conceptual/conceptual-1.5.1b.ebuild')
-rw-r--r--dev-lang/conceptual/conceptual-1.5.1b.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-lang/conceptual/conceptual-1.5.1b.ebuild b/dev-lang/conceptual/conceptual-1.5.1b.ebuild
deleted file mode 100644
index 53cfee813..000000000
--- a/dev-lang/conceptual/conceptual-1.5.1b.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-JAVA_PKG_OPT_USE="gui"
-
-inherit java-pkg-opt-2 python-single-r1
-
-DESCRIPTION="A Network Correctness and Performance Testing Language"
-HOMEPAGE="http://conceptual.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD-2"
-IUSE="gui"
-KEYWORDS="~amd64"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- virtual/mpi
- ${PYTHON_DEPS}
- gui? (
- virtual/jdk:*
- dev-java/jython
- )"
-DEPEND="${RDEPEND}"
-
-src_compile() {
- default
- use gui && emake gui
-}
-
-src_install () {
- default
- if use gui; then
- java-pkg_newjar gui/ncptlGUI-1.5.1b.jar ${PN}.jar
- java-pkg_dolauncher
- fi
- python_optimize
-}