aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/icc/icc-12.0.2.137.ebuild')
-rw-r--r--dev-lang/icc/icc-12.0.2.137.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-lang/icc/icc-12.0.2.137.ebuild b/dev-lang/icc/icc-12.0.2.137.ebuild
new file mode 100644
index 000000000..ec0f44c10
--- /dev/null
+++ b/dev-lang/icc/icc-12.0.2.137.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+INTEL_DPN=parallel_studio_xe
+INTEL_DID=2065
+INTEL_DPV=2011_update1
+INTEL_SUBDIR=composerxe
+
+inherit intel-sdp
+
+DESCRIPTION="Intel C/C++ Compiler"
+HOMEPAGE="http://software.intel.com/en-us/articles/intel-composer-xe/"
+
+IUSE="eclipse"
+DEPEND="~dev-libs/intel-common-${PV}[compiler]"
+RDEPEND="${DEPEND}
+ eclipse? ( dev-util/eclipse-sdk )"
+
+QA_PREBUILT="
+ ${INTEL_SDP_DIR}/bin/*/*
+ ${INTEL_SDP_DIR}/compiler/lib/*/*
+ ${INTEL_SDP_DIR}/mpirt/bin/*/*
+ ${INTEL_SDP_DIR}/mpirt/lib/*/*"
+QA_PRESTRIPPED="${INTEL_SDP_DIR}/compiler/lib/*/.*libFNP.so"
+
+INTEL_BIN_RPMS="compilerproc compilerproc-devel"
+INTEL_DAT_RPMS="compilerproc-common"