aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/boost-compute')
-rw-r--r--dev-libs/boost-compute/Manifest3
-rw-r--r--dev-libs/boost-compute/boost-compute-0.4-r1.ebuild25
-rw-r--r--dev-libs/boost-compute/boost-compute-0.5.ebuild23
-rw-r--r--dev-libs/boost-compute/boost-compute-1.74.0.ebuild50
-rw-r--r--dev-libs/boost-compute/boost-compute-9999.ebuild23
-rw-r--r--dev-libs/boost-compute/files/boost-compute-0.4-CMakeLists.patch14
-rw-r--r--dev-libs/boost-compute/files/boost-compute-1.74.0-libdir.patch13
-rw-r--r--dev-libs/boost-compute/metadata.xml27
8 files changed, 84 insertions, 94 deletions
diff --git a/dev-libs/boost-compute/Manifest b/dev-libs/boost-compute/Manifest
index cc8fea806..60b962d99 100644
--- a/dev-libs/boost-compute/Manifest
+++ b/dev-libs/boost-compute/Manifest
@@ -1,2 +1 @@
-DIST boost-compute-0.4.tar.gz 282477 BLAKE2B 0160ae319c54fe93162471b4db5520f08016c1837e9d1140b2362ef403466bb7e486310784a6b29b1aefb38425e575686091f4821b5e33998592ec2ebb401f0f SHA512 7a2b4f227b2f0a46ba44aeddc4b562e125949f262ef057c92b9261c9e0fa7a824323b3dbb0bb5129b76fce4be93bbb1fccf5d681d63663731c83c3ab80e5ceed
-DIST boost-compute-0.5.tar.gz 333192 BLAKE2B 08ef2978db4d3f3dce4c03c00496cb4823cf97947c1bb1780fe9a9e3d0fa8c8233e936a1bedbe16a5ef217ac5abca50bf64d3f11cde5f9d6ac4cb24b8ca9f59a SHA512 1caa067342698ec3a6a8e23aaf194f8ced41ac9d5b5a6d3d195911116af4a8a778667065681a8b0e0004887258d7cae71f3c7187ebc50c390200d66fd8688002
+DIST boost-compute-1.74.0.tar.gz 376653 BLAKE2B 72a1f76ab865e17270561699c02f6fcbfc6efa657fd5b6ce774039590bb8ca2dbd95a22721d669cbaa1764c52b63a360c12112cec19ca830288c6315c23fb888 SHA512 484fa370cc4dc98d40a6d0227d1313ff8097653390fde87928963b32bc30e43b0c81da542cc85bb17cfc6348e801d244fe177e6640f825b7899e5f0a6884ad46
diff --git a/dev-libs/boost-compute/boost-compute-0.4-r1.ebuild b/dev-libs/boost-compute/boost-compute-0.4-r1.ebuild
deleted file mode 100644
index 2c52edf3c..000000000
--- a/dev-libs/boost-compute/boost-compute-0.4-r1.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils cmake-utils
-
-DESCRIPTION="A header-only C++ Computing Library for OpenCL"
-HOMEPAGE="https://github.com/boostorg/compute"
-SRC_URI="https://github.com/boostorg/compute/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Boost-1.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-RDEPEND="
- dev-libs/boost
- virtual/opencl
-"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/compute-${PV}"
-
-PATCHES=( "${FILESDIR}/${P}"-CMakeLists.patch )
diff --git a/dev-libs/boost-compute/boost-compute-0.5.ebuild b/dev-libs/boost-compute/boost-compute-0.5.ebuild
deleted file mode 100644
index 8ae88db9d..000000000
--- a/dev-libs/boost-compute/boost-compute-0.5.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils cmake-utils
-
-DESCRIPTION="A header-only C++ Computing Library for OpenCL"
-HOMEPAGE="https://github.com/boostorg/compute"
-SRC_URI="https://github.com/boostorg/compute/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Boost-1.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-RDEPEND="
- dev-libs/boost
- virtual/opencl
-"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/compute-${PV}"
diff --git a/dev-libs/boost-compute/boost-compute-1.74.0.ebuild b/dev-libs/boost-compute/boost-compute-1.74.0.ebuild
new file mode 100644
index 000000000..3e986bda0
--- /dev/null
+++ b/dev-libs/boost-compute/boost-compute-1.74.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="A header-only C++ Computing Library for OpenCL"
+HOMEPAGE="https://github.com/boostorg/compute"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/boostorg/compute"
+else
+ SRC_URI="https://github.com/boostorg/compute/archive/boost-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/compute-boost-${PV}
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="Boost-1.0"
+SLOT="0"
+IUSE="benchmark bolt cache cpp11 cuda eigen examples opencv qt tbb test threads vtk"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/boost
+ virtual/opencl
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-libdir.patch )
+
+src_configure() {
+ local mycmakeargs=(
+ -DBOOST_COMPUTE_USE_OFFLINE_CACHE=$(usex cache)
+ -DBOOST_COMPUTE_USE_CPP11=$(usex cpp11)
+ -DBOOST_COMPUTE_THREAD_SAFE=$(usex threads)
+ -DBOOST_COMPUTE_HAVE_EIGEN=$(usex eigen)
+ -DBOOST_COMPUTE_HAVE_OPENCV=$(usex opencv)
+ -DBOOST_COMPUTE_HAVE_QT=$(usex qt)
+ -DBOOST_COMPUTE_HAVE_VTK=$(usex vtk)
+ -DBOOST_COMPUTE_HAVE_CUDA=$(usex cuda)
+ -DBOOST_COMPUTE_HAVE_TBB=$(usex tbb)
+ -DBOOST_COMPUTE_HAVE_BOLT=$(usex bolt)
+ -DBOOST_COMPUTE_BUILD_TESTS=$(usex test)
+ -DBOOST_COMPUTE_BUILD_BENCHMARKS=$(usex benchmark)
+ -DBOOST_COMPUTE_BUILD_EXAMPLES=$(usex examples)
+ )
+ cmake_src_configure
+}
diff --git a/dev-libs/boost-compute/boost-compute-9999.ebuild b/dev-libs/boost-compute/boost-compute-9999.ebuild
deleted file mode 100644
index fd7276a2d..000000000
--- a/dev-libs/boost-compute/boost-compute-9999.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils cmake-utils git-r3
-
-DESCRIPTION="A header-only C++ Computing Library for OpenCL"
-HOMEPAGE="https://github.com/boostorg/compute"
-EGIT_REPO_URI="
- https://github.com/boostorg/compute.git
- git://github.com/boostorg/compute.git"
-
-LICENSE="Boost-1.0"
-SLOT="0"
-KEYWORDS=""
-IUSE=""
-
-RDEPEND="
- dev-libs/boost
- virtual/opencl
-"
-DEPEND="${RDEPEND}"
diff --git a/dev-libs/boost-compute/files/boost-compute-0.4-CMakeLists.patch b/dev-libs/boost-compute/files/boost-compute-0.4-CMakeLists.patch
deleted file mode 100644
index 86d3a9e29..000000000
--- a/dev-libs/boost-compute/files/boost-compute-0.4-CMakeLists.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Install the BoostComputeConfig to /usr/lib/cmake instead of /usr/share/cmake.
-
-Patch by Marius Brehler.
---- CMakeLists.txt
-+++ CMakeLists.txt
-@@ -81,7 +81,7 @@ configure_file(
- # install cmake config file
- install(
- FILES ${BoostCompute_BINARY_DIR}/BoostComputeConfig.cmake
-- DESTINATION share/cmake/BoostCompute
-+ DESTINATION lib/cmake/BoostCompute
- )
-
- # install header files
diff --git a/dev-libs/boost-compute/files/boost-compute-1.74.0-libdir.patch b/dev-libs/boost-compute/files/boost-compute-1.74.0-libdir.patch
new file mode 100644
index 000000000..9b35a5284
--- /dev/null
+++ b/dev-libs/boost-compute/files/boost-compute-1.74.0-libdir.patch
@@ -0,0 +1,13 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index d0327ca..e52a62a 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -122,7 +122,7 @@ configure_file(
+ # install cmake config file
+ install(
+ FILES ${BoostCompute_BINARY_DIR}/BoostComputeConfig.cmake
+- DESTINATION lib/cmake/BoostCompute
++ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/BoostCompute
+ )
+
+ # install header files
diff --git a/dev-libs/boost-compute/metadata.xml b/dev-libs/boost-compute/metadata.xml
index f41b18fa7..21973c648 100644
--- a/dev-libs/boost-compute/metadata.xml
+++ b/dev-libs/boost-compute/metadata.xml
@@ -2,20 +2,33 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
- <email>marbre@linux.sungazer.de</email>
- <name>Marius Brehler</name>
+ <email>gentoo@aisha.cc</email>
+ <name>Aisha Tammy</name>
</maintainer>
<maintainer type="project">
<email>sci@gentoo.org</email>
<name>Gentoo Science Project</name>
</maintainer>
<longdescription>
-Boost.Compute is a GPU/parallel-computing library for C++ based on
-OpenCL. The core library is a thin C++ wrapper over the OpenCL API
-and provides access to compute devices, contexts, command queues
-and memory buffers.
-</longdescription>
+ Boost.Compute is a GPU/parallel-computing library for C++ based on
+ OpenCL. The core library is a thin C++ wrapper over the OpenCL API
+ and provides access to compute devices, contexts, command queues
+ and memory buffers.
+ </longdescription>
<upstream>
<remote-id type="github">boostorg/compute</remote-id>
</upstream>
+ <use>
+ <flag name="benchmark">build benchmark examples</flag>
+ <flag name="bolt">build bolt examples and tests</flag>
+ <flag name="cpp11">enable C++11 features in examples and tests</flag>
+ <flag name="cache">use offline cache for opencl binaries in examples and tests</flag>
+ <flag name="cuda">build cuda examples and tests</flag>
+ <flag name="eigen">build eigen examples and tests</flag>
+ <flag name="opencv">build opencv examples and tests</flag>
+ <flag name="qt">build qt examples and tests</flag>
+ <flag name="tbb">build examples and tests using tbb backend</flag>
+ <flag name="threads">build thread safe examples and tests</flag>
+ <flag name="vtk">build vtk examples and tests</flag>
+ </use>
</pkgmetadata>