aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/zarith/zarith-1.1.ebuild')
-rw-r--r--dev-ml/zarith/zarith-1.1.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-ml/zarith/zarith-1.1.ebuild b/dev-ml/zarith/zarith-1.1.ebuild
deleted file mode 100644
index dc8c685cb..000000000
--- a/dev-ml/zarith/zarith-1.1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=5
-
-DESCRIPTION="The Zarith library implements arithmetic and logical operations over arbitrary-precision integers"
-HOMEPAGE="http://forge.ocamlcore.org/projects/zarith"
-SRC_URI="http://forge.ocamlcore.org/frs/download.php/835/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="+ocamlopt"
-
-DEPEND="
- >=dev-lang/ocaml-3.10.2[ocamlopt?]
- dev-libs/gmp"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- OCAMLDIR=$(ocamlc -where)
-}
-
-src_prepare(){
- sed \
- -e "s:(OCAMLFIND) install:(OCAMLFIND) install -ldconf \$(INSTALLDIR)/ld.conf:g" \
- -i "${S}"/project.mak || die
-}
-
-src_configure(){
- ./configure -installdir "${D}${OCAMLDIR}" || die
-}
-
-src_install(){
- dodir "${OCAMLDIR}"
- cp "${OCAMLDIR}/ld.conf" "${D}${OCAMLDIR}/ld.conf" || die
- emake install
- rm "${D}${OCAMLDIR}/ld.conf" || die
- dodoc Changes README
-}