aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/annexremote/annexremote-1.5.0.ebuild')
-rw-r--r--dev-python/annexremote/annexremote-1.5.0.ebuild26
1 files changed, 7 insertions, 19 deletions
diff --git a/dev-python/annexremote/annexremote-1.5.0.ebuild b/dev-python/annexremote/annexremote-1.5.0.ebuild
index 94549009e..a6dacd5c9 100644
--- a/dev-python/annexremote/annexremote-1.5.0.ebuild
+++ b/dev-python/annexremote/annexremote-1.5.0.ebuild
@@ -1,34 +1,22 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-MY_PN="AnnexRemote"
-MY_P="${MY_PN}-${PV}"
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+inherit distutils-r1 pypi
DESCRIPTION="Helper module to easily develop git-annex remotes"
HOMEPAGE="https://github.com/Lykos153/AnnexRemote"
-SRC_URI="https://github.com/Lykos153/AnnexRemote/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="examples"
-
-S="${WORKDIR}/${MY_P}"
-
-COMMON_DEPEND="dev-python/future[${PYTHON_USEDEP}]"
-RDEPEND="
- ${COMMON_DEPEND}
-"
-DEPEND="
- ${COMMON_DEPEND}
-"
-
-distutils_enable_tests nose
+# Tests require nose, reported upstream:
+# https://github.com/Lykos153/AnnexRemote/issues/61
+RESTRICT="test"
python_install_all() {
distutils-r1_python_install_all