aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/arrayfire-python/arrayfire-python-3.6.20181017.ebuild')
-rw-r--r--dev-python/arrayfire-python/arrayfire-python-3.6.20181017.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/arrayfire-python/arrayfire-python-3.6.20181017.ebuild b/dev-python/arrayfire-python/arrayfire-python-3.6.20181017.ebuild
new file mode 100644
index 000000000..8c5542a86
--- /dev/null
+++ b/dev-python/arrayfire-python/arrayfire-python-3.6.20181017.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for ArrayFire"
+HOMEPAGE="http://www.arrayfire.com"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/arrayfire/arrayfire-python"
+else
+ SRC_URI="https://github.com/arrayfire/arrayfire-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ sci-libs/arrayfire
+"
+DEPEND="${RDEPEND}"
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ ${EPYTHON} -m arrayfire.tests || \
+ die "tests failed with ${EPYTHON}"
+}