aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/asciidata/asciidata-1.1.ebuild')
-rw-r--r--dev-python/asciidata/asciidata-1.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/asciidata/asciidata-1.1.ebuild b/dev-python/asciidata/asciidata-1.1.ebuild
new file mode 100644
index 000000000..7d0aa9f2b
--- /dev/null
+++ b/dev-python/asciidata/asciidata-1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit distutils
+
+DESCRIPTION="Python module to handle ASCII tables"
+SRC_URI="http://www.stecf.org/software/PYTHONtools/astro${PN}/source/${P}.tar.gz
+ doc? ( http://www.stecf.org/software/PYTHONtools/astro${PN}/manual/${PN}_${PV}.tar.gz )"
+HOMEPAGE="http://www.stecf.org/software/astroasciidata/index.html"
+
+RDEPEND="dev-python/numpy"
+DEPEND="test? ( dev-python/numpy )"
+IUSE="doc"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2"
+
+src_test() {
+ PYTHONPATH=build/lib ${python} setup.py test || die "tests failed"
+}
+
+src_install() {
+ distutils_src_install
+ use doc && dohtml "${WORKDIR}"/asciidata/*
+}