aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/astropy')
-rw-r--r--dev-python/astropy/Manifest2
-rw-r--r--dev-python/astropy/astropy-5.2.1.ebuild (renamed from dev-python/astropy/astropy-4.2.ebuild)24
-rw-r--r--dev-python/astropy/metadata.xml3
3 files changed, 17 insertions, 12 deletions
diff --git a/dev-python/astropy/Manifest b/dev-python/astropy/Manifest
index 0bacc3982..3d86b9bab 100644
--- a/dev-python/astropy/Manifest
+++ b/dev-python/astropy/Manifest
@@ -1 +1 @@
-DIST astropy-4.2.tar.gz 7462293 BLAKE2B 47a26cde10e99be3c2ea0e5f2e6fb90afc70a27c53bad63683c0cd6ca7a97ff45542d68c8326bbfcae23135594b1a2533eccdb54aec1e62ddc0ff11cb78aa263 SHA512 14bb90aac13f3fe668114ebe578aac401987e8e2cd2bb9fb0971e5b8e9f8df6a594d454bb53e330807c3854c44d295e2b4dc96b57ccb69e5f53ee11356869d9d
+DIST astropy-5.2.1.tar.gz 8284422 BLAKE2B ded3556d6b16fe7abbbd019c23c0297f4690b13f054a1b98ab6aaeb20b92debefbc6e7c6c5eff8c65dfaa271826885027d6ba4a92f94218632162501a30b025b SHA512 46da7b065e119fa36233ced928abab31d6022fd116d2ed6825cb88b456ab57130772eea1de8cff7b5b7f30aadf46b933ad56a47cf6d2d68c0fa7593f322a6ea0
diff --git a/dev-python/astropy/astropy-4.2.ebuild b/dev-python/astropy/astropy-5.2.1.ebuild
index 9b17173a4..b52d1e6f5 100644
--- a/dev-python/astropy/astropy-4.2.ebuild
+++ b/dev-python/astropy/astropy-5.2.1.ebuild
@@ -1,22 +1,21 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1
+inherit distutils-r1 pypi
DESCRIPTION="Core functionality for performing astrophysics with Python"
-HOMEPAGE="https://astropy.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="https://www.astropy.org/"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
#TODO: Package all these pytest deps:
-# pytest-doctestplus>=0.2.0
# pytest-remotedata>=0.3.1
# pytest-openfiles>=0.3.1
# pytest-astropy-header>=0.1.2
@@ -26,17 +25,20 @@ RESTRICT="test"
RDEPEND="
dev-libs/expat:0=
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pyerfa[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.18[${PYTHON_USEDEP}]
+ >=dev-python/pyerfa-2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.13[${PYTHON_USEDEP}]
+ >=dev-python/packaging-19.0[${PYTHON_USEDEP}]
sci-astronomy/wcslib:0=
>=sci-libs/cfitsio-3.350:0=
sys-libs/zlib:0=
"
-BDEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
dev-python/astropy-helpers[${PYTHON_USEDEP}]
dev-python/extension-helpers[${PYTHON_USEDEP}]
dev-python/cython[${PYTHON_USEDEP}]
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
test? (
dev-libs/libxml2
dev-python/h5py[${PYTHON_USEDEP}]
diff --git a/dev-python/astropy/metadata.xml b/dev-python/astropy/metadata.xml
index 3d1dc456d..3891d8cc8 100644
--- a/dev-python/astropy/metadata.xml
+++ b/dev-python/astropy/metadata.xml
@@ -9,4 +9,7 @@
<email>sci-astronomy@gentoo.org</email>
<name>Gentoo Astronomy Project</name>
</maintainer>
+ <upstream>
+ <remote-id type="pypi">astropy</remote-id>
+ </upstream>
</pkgmetadata>