aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/astroquery/astroquery-0.4.1.ebuild')
-rw-r--r--dev-python/astroquery/astroquery-0.4.1.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/astroquery/astroquery-0.4.1.ebuild b/dev-python/astroquery/astroquery-0.4.1.ebuild
deleted file mode 100644
index a7884eb1d..000000000
--- a/dev-python/astroquery/astroquery-0.4.1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-inherit distutils-r1
-
-DESCRIPTION="A collection of packages to access online astronomical resources"
-HOMEPAGE="https://www.astropy.org/astroquery/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-#TODO: Package all these pytest deps:
-# pytest-doctestplus>=0.2.0
-# pytest-remotedata>=0.3.1
-# pytest-openfiles>=0.3.1
-# pytest-astropy-header>=0.1.2
-# pytest-arraydiff>=0.1
-# pytest-filter-subpackage>=0.1
-RESTRICT="test"
-
-RDEPEND="
- >=dev-python/astropy-0.2[${PYTHON_USEDEP}]
- dev-python/beautifulsoup4[${PYTHON_USEDEP}]
- dev-python/html5lib[${PYTHON_USEDEP}]
- dev-python/keyring[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-
-BDEPEND="test? (
- dev-python/photutils[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
-)"
-
-# TODO: Fix this
-# NameError: name 'disabled_intersphinx_mapping' is not defined
-#distutils_enable_sphinx docs dev-python/sphinx-astropy
-distutils_enable_tests pytest