aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/astroscrappy/astroscrappy-1.1.0-r1.ebuild')
-rw-r--r--dev-python/astroscrappy/astroscrappy-1.1.0-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/astroscrappy/astroscrappy-1.1.0-r1.ebuild b/dev-python/astroscrappy/astroscrappy-1.1.0-r1.ebuild
new file mode 100644
index 000000000..cd34136af
--- /dev/null
+++ b/dev-python/astroscrappy/astroscrappy-1.1.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Speedy Cosmic Ray Annihilation Package in Python"
+HOMEPAGE="https://github.com/astropy/astroscrappy"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+#TODO: Fix this
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/astropy-2.0[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+# Requires self to already be installed
+#distutils_enable_sphinx docs dev-python/sphinx-astropy
+distutils_enable_tests pytest