aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/atpy/atpy-0.9.1.ebuild')
-rw-r--r--dev-python/atpy/atpy-0.9.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/atpy/atpy-0.9.1.ebuild b/dev-python/atpy/atpy-0.9.1.ebuild
new file mode 100644
index 000000000..8407bc278
--- /dev/null
+++ b/dev-python/atpy/atpy-0.9.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+inherit distutils
+
+MYPN=ATpy
+MYP="${MYPN}-${PV}"
+
+DESCRIPTION="Astronomical tables support Python"
+HOMEPAGE="http://atpy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MYP}.tar.gz"
+
+RDEPEND=">=dev-python/numpy-1.3
+ fits? ( >=dev-python/pyfits-2.1 )
+ mysql? ( dev-python/mysql-python )
+ postgres? ( dev-db/pygresql )
+ sqlite? ( dev-python/pysqlite )
+ votable? ( >=dev-python/vo-0.3 )"
+
+DEPEND=">=dev-python/numpy-1.3"
+
+IUSE="+fits mysql postgres sqlite +votable"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-3"
+
+S="${WORKDIR}/${MYP}"
+
+src_test() {
+ PYTHONPATH=$(dir -d build/lib*) "${python}" test/test.py || die
+}