aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/bz2file/bz2file-0.98.ebuild')
-rw-r--r--dev-python/bz2file/bz2file-0.98.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/dev-python/bz2file/bz2file-0.98.ebuild b/dev-python/bz2file/bz2file-0.98.ebuild
index 0021a9536..0324854a1 100644
--- a/dev-python/bz2file/bz2file-0.98.ebuild
+++ b/dev-python/bz2file/bz2file-0.98.ebuild
@@ -15,3 +15,9 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+PATCHES=( "${FILESDIR}"/${P}-always-threading.patch )
+
+python_test() {
+ distutils_install_for_testing
+ ${EPYTHON} test_bz2file.py || die "tests failed for ${EPYTHON}"
+}