aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/colormath/colormath-3.0.0.ebuild')
-rw-r--r--dev-python/colormath/colormath-3.0.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/colormath/colormath-3.0.0.ebuild b/dev-python/colormath/colormath-3.0.0.ebuild
new file mode 100644
index 000000000..8bd5a2b02
--- /dev/null
+++ b/dev-python/colormath/colormath-3.0.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit pypi distutils-r1
+
+DESCRIPTION="Easy color scales and color conversion for Python"
+HOMEPAGE="https://pypi.org/project/colormath/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~amd64-linux"
+
+RDEPEND="dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]"
+
+# Nose test no longer supported
+RESTRICT="test"
+#distutils_enable_tests nose