aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/datrie/datrie-0.8.2-r1.ebuild')
-rw-r--r--dev-python/datrie/datrie-0.8.2-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/datrie/datrie-0.8.2-r1.ebuild b/dev-python/datrie/datrie-0.8.2-r1.ebuild
new file mode 100644
index 000000000..e8f9f9336
--- /dev/null
+++ b/dev-python/datrie/datrie-0.8.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+# Fails to compile with pep517
+#DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Implements a topological sort algorithm"
+HOMEPAGE="https://github.com/pytries/datrie"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # do not depend on pytest-runner
+ sed -i "/pytest-runner/d" setup.py || die
+ distutils-r1_python_prepare_all
+}