aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/datrie/datrie-0.8.2.ebuild')
-rw-r--r--dev-python/datrie/datrie-0.8.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/datrie/datrie-0.8.2.ebuild b/dev-python/datrie/datrie-0.8.2.ebuild
new file mode 100644
index 000000000..de547910d
--- /dev/null
+++ b/dev-python/datrie/datrie-0.8.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Implements a topological sort algorithm"
+HOMEPAGE="https://gitlab.com/ericvsmith/toposort"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # do not depend on pytest-runner
+ sed -i "/pytest-runner/d" setup.py || die
+ distutils-r1_python_prepare_all
+}