aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/docstring-parser/docstring-parser-0.16.ebuild')
-rw-r--r--dev-python/docstring-parser/docstring-parser-0.16.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/docstring-parser/docstring-parser-0.16.ebuild b/dev-python/docstring-parser/docstring-parser-0.16.ebuild
new file mode 100644
index 000000000..1d82de77c
--- /dev/null
+++ b/dev-python/docstring-parser/docstring-parser-0.16.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Parse Python docstrings in various flavors"
+HOMEPAGE="https://github.com/rr-/docstring_parser"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest