aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dpctl')
-rw-r--r--dev-python/dpctl/Manifest4
-rw-r--r--dev-python/dpctl/dpctl-0.14.1_rc2.ebuild (renamed from dev-python/dpctl/dpctl-0.14.0.ebuild)21
-rw-r--r--dev-python/dpctl/dpctl-0.14.5.ebuild (renamed from dev-python/dpctl/dpctl-0.13.0.ebuild)37
-rw-r--r--dev-python/dpctl/files/dpctl-0.13.0-dont-fetch-pybind.patch21
-rw-r--r--dev-python/dpctl/files/dpctl-0.14.0-include-tuple.patch47
-rw-r--r--dev-python/dpctl/files/dpctl-0.14.1_rc2-dont-fetch-level-zero.patch (renamed from dev-python/dpctl/files/dpctl-0.14.0-dont-fetch-level-zero.patch)10
-rw-r--r--dev-python/dpctl/files/dpctl-0.14.1_rc2-dont-fetch-pybind.patch (renamed from dev-python/dpctl/files/dpctl-0.14.0-dont-fetch-pybind.patch)8
7 files changed, 47 insertions, 101 deletions
diff --git a/dev-python/dpctl/Manifest b/dev-python/dpctl/Manifest
index aab57723a..d402c3e9e 100644
--- a/dev-python/dpctl/Manifest
+++ b/dev-python/dpctl/Manifest
@@ -1,2 +1,2 @@
-DIST dpctl-0.13.0.gh.tar.gz 363708 BLAKE2B 82eaf296cb0aaaad1a9c23334b027d4b38ef8d580c43a6ea1fb7542b20f5511c09edf7fdd3bd98a5b48cdf55176fcaeea787c6d93ef65fc6c94004cbb0c61255 SHA512 5ddefe9671ef77e0ff507e3c92c80b147a4f19f50ee9b64dd940960e181edea16b5dbbdb990aa3dc37da80e6015979f702fba60210b8677a83780224cdd30e76
-DIST dpctl-0.14.0.gh.tar.gz 399378 BLAKE2B 3a9cbea965941c8c0a85938f0736705fd0bbdc611e02a44363a670119555ff95fbae130526caa25f42ee499d5b36c83b8c574db1b2368a1cbe7855b84fabe9f1 SHA512 37d76653112556ebeadec846cc6b156cb84e7b82bc6a9477072a3721b3a830c5fcb7d6e92e76aa7c7449547e925b07d5dda42d2777813e7d1db1d97ea852e22a
+DIST dpctl-0.14.1_rc2.gh.tar.gz 409028 BLAKE2B 481be08bb6a7b1a439580d600b0e14036f10793e568314f9373ffa46daad7d3e43d33fc66c3c48ec7e3de71e9d0a7256cdfdd984c38fa7f1694dcc0227dae93f SHA512 91ab20a51893e3afc9e140ab9dfd1aa19b24e58227a001faefb9ceba6ffc4aa235214663c7456e977acf556796be097eabacc9b01b94eb42e8c70677a2f2dd9d
+DIST dpctl-0.14.5.gh.tar.gz 552066 BLAKE2B f668ceea99125dad1e0a6989db5bd59df087840d09b1a1538c38cddd0f482f4fc4053ef400e86ddedee4b1906575a441fb97d2caaf3c3718d8aac503d942c0b5 SHA512 6df39eec93da38b86df4cdfdf90350ff11f95d4884bb762289af9b0a6e240d45ed7cc7243677ca7403b042f8938f8acfa42a974d6cff673cd846c0b0f22d0803
diff --git a/dev-python/dpctl/dpctl-0.14.0.ebuild b/dev-python/dpctl/dpctl-0.14.1_rc2.ebuild
index 0bab26875..4ef429b97 100644
--- a/dev-python/dpctl/dpctl-0.14.0.ebuild
+++ b/dev-python/dpctl/dpctl-0.14.1_rc2.ebuild
@@ -3,13 +3,14 @@
EAPI=8
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1
DESCRIPTION="Data Parallel Control "
HOMEPAGE="https://github.com/IntelPython/dpctl"
-SRC_URI="https://github.com/IntelPython/dpctl/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+SRC_URI="https://github.com/IntelPython/dpctl/archive/refs/tags/${PV//_rc/dev}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${PN}-${PV//_rc/dev}"
LICENSE="Apache-2.0"
SLOT="0"
@@ -20,7 +21,7 @@ BDEPEND="
dev-python/scikit-build[${PYTHON_USEDEP}]
dev-python/pybind11[${PYTHON_USEDEP}]
dev-python/versioneer[${PYTHON_USEDEP}]
- dev-util/cmake
+ dev-build/cmake
dev-vcs/git
sys-devel/DPC++
"
@@ -36,10 +37,10 @@ DEPEND="
RDEPEND="${DEPEND}"
PATCHES=(
- "${FILESDIR}/${P}-find-opencl.patch"
- "${FILESDIR}/${P}-dont-fetch-level-zero.patch"
- "${FILESDIR}/${P}-dont-fetch-pybind.patch"
- "${FILESDIR}/${P}-include-tuple.patch"
+ "${FILESDIR}/${PN}-0.14.0-find-opencl.patch"
+ "${FILESDIR}/${PN}-0.14.1_rc2-dont-fetch-level-zero.patch"
+ "${FILESDIR}/${PN}-0.14.1_rc2-dont-fetch-pybind.patch"
+ #"${FILESDIR}/${PN}-0.14.1_rc2-include-tuple.patch"
)
distutils_enable_tests pytest
@@ -60,3 +61,9 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
+
+python_test() {
+ export PYTHONPATH="${BUILD_DIR}/install/usr/lib/${EPYTHON}/site-packages"
+ # We don't use epytest because it overwrites our PYTHONPATH
+ pytest -vv || die
+}
diff --git a/dev-python/dpctl/dpctl-0.13.0.ebuild b/dev-python/dpctl/dpctl-0.14.5.ebuild
index 4c240bfb1..4ef429b97 100644
--- a/dev-python/dpctl/dpctl-0.13.0.ebuild
+++ b/dev-python/dpctl/dpctl-0.14.5.ebuild
@@ -3,13 +3,14 @@
EAPI=8
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1
DESCRIPTION="Data Parallel Control "
HOMEPAGE="https://github.com/IntelPython/dpctl"
-SRC_URI="https://github.com/IntelPython/dpctl/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+SRC_URI="https://github.com/IntelPython/dpctl/archive/refs/tags/${PV//_rc/dev}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${PN}-${PV//_rc/dev}"
LICENSE="Apache-2.0"
SLOT="0"
@@ -20,7 +21,7 @@ BDEPEND="
dev-python/scikit-build[${PYTHON_USEDEP}]
dev-python/pybind11[${PYTHON_USEDEP}]
dev-python/versioneer[${PYTHON_USEDEP}]
- dev-util/cmake
+ dev-build/cmake
dev-vcs/git
sys-devel/DPC++
"
@@ -31,13 +32,15 @@ DEPEND="
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/wheel[${PYTHON_USEDEP}]
sci-libs/oneDAL
- sys-devel/DPC++:0/5
+ sys-devel/DPC++:0/6
"
RDEPEND="${DEPEND}"
PATCHES=(
- "${FILESDIR}/${PN}-0.14.0-dont-fetch-level-zero.patch"
- "${FILESDIR}/${PN}-0.13.0-dont-fetch-pybind.patch"
+ "${FILESDIR}/${PN}-0.14.0-find-opencl.patch"
+ "${FILESDIR}/${PN}-0.14.1_rc2-dont-fetch-level-zero.patch"
+ "${FILESDIR}/${PN}-0.14.1_rc2-dont-fetch-pybind.patch"
+ #"${FILESDIR}/${PN}-0.14.1_rc2-include-tuple.patch"
)
distutils_enable_tests pytest
@@ -48,15 +51,19 @@ python_prepare_all() {
export CXX="${ESYSROOT}/usr/lib/llvm/intel/bin/clang++"
export DPCPPROOT="${ESYSROOT}/usr/lib/llvm/intel"
- # For some reason this is required to build successfully
- mkdir -p _skbuild/linux-x86_64-3.8/setuptools/lib.linux-x86_64-cpython-38/dpctl || die
- cp dpctl/_version.py _skbuild/linux-x86_64-3.8/setuptools/lib.linux-x86_64-cpython-38/dpctl || die
- mkdir -p _skbuild/linux-x86_64-3.9/setuptools/lib.linux-x86_64-cpython-39/dpctl || die
- cp dpctl/_version.py _skbuild/linux-x86_64-3.9/setuptools/lib.linux-x86_64-cpython-39/dpctl || die
- mkdir -p _skbuild/linux-x86_64-3.10/setuptools/lib.linux-x86_64-cpython-310/dpctl || die
- cp dpctl/_version.py _skbuild/linux-x86_64-3.10/setuptools/lib.linux-x86_64-cpython-310/dpctl || die
- mkdir -p _skbuild/linux-x86_64-3.11/setuptools/lib.linux-x86_64-cpython-311/dpctl || die
- cp dpctl/_version.py _skbuild/linux-x86_64-3.11/setuptools/lib.linux-x86_64-cpython-311/dpctl || die
+ # Build system reads version from git tag
+ git init -q || die
+ git config --global user.email "larry@gentoo.org" || die
+ git config --global user.name "Larry the Cow" || die
+ git add . || die
+ git commit -qm "init" || die
+ git tag -a "${PV}" -m "${PN} version ${PV}" || die
distutils-r1_python_prepare_all
}
+
+python_test() {
+ export PYTHONPATH="${BUILD_DIR}/install/usr/lib/${EPYTHON}/site-packages"
+ # We don't use epytest because it overwrites our PYTHONPATH
+ pytest -vv || die
+}
diff --git a/dev-python/dpctl/files/dpctl-0.13.0-dont-fetch-pybind.patch b/dev-python/dpctl/files/dpctl-0.13.0-dont-fetch-pybind.patch
deleted file mode 100644
index b7dab5c75..000000000
--- a/dev-python/dpctl/files/dpctl-0.13.0-dont-fetch-pybind.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 23ae1dd..e144e90 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -26,15 +26,7 @@ install(FILES ${_dpctl_capi_headers}
- # Define CMAKE_INSTALL_xxx: LIBDIR, INCLUDEDIR
- include(GNUInstallDirs)
-
--# Fetch pybind11
--include(FetchContent)
--
--FetchContent_Declare(
-- pybind11
-- URL https://github.com/pybind/pybind11/archive/refs/tags/v2.9.2.tar.gz
-- URL_HASH SHA256=6bd528c4dbe2276635dc787b6b1f2e5316cf6b49ee3e150264e455a0d68d19c1
--)
--FetchContent_MakeAvailable(pybind11)
-+include(/usr/share/cmake/pybind11/pybind11Config.cmake)
-
- add_subdirectory(dpctl)
-
diff --git a/dev-python/dpctl/files/dpctl-0.14.0-include-tuple.patch b/dev-python/dpctl/files/dpctl-0.14.0-include-tuple.patch
deleted file mode 100644
index 44b950cb6..000000000
--- a/dev-python/dpctl/files/dpctl-0.14.0-include-tuple.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-From d0d3e6f1a9ffbac91f24cc06abce6dcad6509a6b Mon Sep 17 00:00:00 2001
-From: Julien Jerphanion <git@jjerphan.xyz>
-Date: Tue, 6 Dec 2022 10:24:26 +0100
-Subject: [PATCH 1/2] MAINT Include tuple in 'utils/strided_iters.hpp'
-
-This include directive seems to have been forgotten and it is impossible
-for me to compile dpctl without it.
----
- dpctl/tensor/libtensor/include/utils/strided_iters.hpp | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/dpctl/tensor/libtensor/include/utils/strided_iters.hpp b/dpctl/tensor/libtensor/include/utils/strided_iters.hpp
-index c24ed54941..595ad3f4a7 100644
---- a/dpctl/tensor/libtensor/include/utils/strided_iters.hpp
-+++ b/dpctl/tensor/libtensor/include/utils/strided_iters.hpp
-@@ -30,6 +30,7 @@
- #include <array>
- #include <numeric> // std::iota
- #include <vector>
-+#include <tuple>
-
- /* An N-dimensional array can be stored in a single
- * contiguous chunk of memory by contiguously laying
-
-From f75ccd8c8aeaae92f0cb03874f93be5e7a63a6a7 Mon Sep 17 00:00:00 2001
-From: Julien Jerphanion <git@jjerphan.xyz>
-Date: Tue, 6 Dec 2022 14:45:40 +0100
-Subject: [PATCH 2/2] Make clang-format happy
-
----
- dpctl/tensor/libtensor/include/utils/strided_iters.hpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/dpctl/tensor/libtensor/include/utils/strided_iters.hpp b/dpctl/tensor/libtensor/include/utils/strided_iters.hpp
-index 595ad3f4a7..0abd7f4f2a 100644
---- a/dpctl/tensor/libtensor/include/utils/strided_iters.hpp
-+++ b/dpctl/tensor/libtensor/include/utils/strided_iters.hpp
-@@ -29,8 +29,8 @@
- #include <algorithm> // sort
- #include <array>
- #include <numeric> // std::iota
--#include <vector>
- #include <tuple>
-+#include <vector>
-
- /* An N-dimensional array can be stored in a single
- * contiguous chunk of memory by contiguously laying
diff --git a/dev-python/dpctl/files/dpctl-0.14.0-dont-fetch-level-zero.patch b/dev-python/dpctl/files/dpctl-0.14.1_rc2-dont-fetch-level-zero.patch
index ac0301886..a7a4adf8b 100644
--- a/dev-python/dpctl/files/dpctl-0.14.0-dont-fetch-level-zero.patch
+++ b/dev-python/dpctl/files/dpctl-0.14.1_rc2-dont-fetch-level-zero.patch
@@ -1,5 +1,5 @@
diff --git a/libsyclinterface/cmake/modules/GetLevelZeroHeaders.cmake b/libsyclinterface/cmake/modules/GetLevelZeroHeaders.cmake
-index 2929c33..731f054 100644
+index fe109fc..55595e9 100644
--- a/libsyclinterface/cmake/modules/GetLevelZeroHeaders.cmake
+++ b/libsyclinterface/cmake/modules/GetLevelZeroHeaders.cmake
@@ -26,76 +26,10 @@
@@ -19,7 +19,7 @@ index 2929c33..731f054 100644
-
- if(NOT result EQUAL 0)
- message(FATAL_ERROR
-- "Could not update Level Zero sources."
+- "Could not update Level Zero sources. Return code: ${result}"
- )
- endif()
- else()
@@ -34,7 +34,7 @@ index 2929c33..731f054 100644
-
- if(NOT result EQUAL 0)
- message(FATAL_ERROR
-- "Could not clone Level Zero sources from github.com/oneapi-src/level-zero."
+- "Could not clone Level Zero sources from github.com/oneapi-src/level-zero. Return code: ${result}"
- )
- endif()
- endif()
@@ -52,7 +52,7 @@ index 2929c33..731f054 100644
-
- if(NOT result EQUAL 0)
- message(FATAL_ERROR
-- "Could not get the name for the latest release."
+- "Could not get the name for the latest release. Return code: ${result}"
- )
- endif()
-
@@ -68,7 +68,7 @@ index 2929c33..731f054 100644
-
- if(NOT result EQUAL 0)
- message(FATAL_ERROR
-- "Could not checkout the latest release."
+- "Could not checkout the latest release. Return code: ${result}"
- )
- endif()
-
diff --git a/dev-python/dpctl/files/dpctl-0.14.0-dont-fetch-pybind.patch b/dev-python/dpctl/files/dpctl-0.14.1_rc2-dont-fetch-pybind.patch
index b2b8c5d81..d56dc27b3 100644
--- a/dev-python/dpctl/files/dpctl-0.14.0-dont-fetch-pybind.patch
+++ b/dev-python/dpctl/files/dpctl-0.14.1_rc2-dont-fetch-pybind.patch
@@ -1,8 +1,8 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index da138c1..ecab139 100644
+index d97ca9a..3914bd9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -28,15 +28,7 @@ install(FILES ${_dpctl_capi_headers}
+@@ -32,15 +32,7 @@ install(FILES ${_dpctl_capi_headers}
# Define CMAKE_INSTALL_xxx: LIBDIR, INCLUDEDIR
include(GNUInstallDirs)
@@ -11,8 +11,8 @@ index da138c1..ecab139 100644
-
-FetchContent_Declare(
- pybind11
-- URL https://github.com/pybind/pybind11/archive/refs/tags/v2.10.1.tar.gz
-- URL_HASH SHA256=111014b516b625083bef701df7880f78c2243835abdb263065b6b59b960b6bad
+- URL https://github.com/pybind/pybind11/archive/refs/tags/v2.10.2.tar.gz
+- URL_HASH SHA256=93bd1e625e43e03028a3ea7389bba5d3f9f2596abc074b068e70f4ef9b1314ae
-)
-FetchContent_MakeAvailable(pybind11)
+include(/usr/share/cmake/pybind11/pybind11Config.cmake)