aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/emcee/emcee-2.0.0.ebuild')
-rw-r--r--dev-python/emcee/emcee-2.0.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/emcee/emcee-2.0.0.ebuild b/dev-python/emcee/emcee-2.0.0.ebuild
new file mode 100644
index 000000000..286e957ae
--- /dev/null
+++ b/dev-python/emcee/emcee-2.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python ensemble sampling toolkit for affine-invariant MCMC"
+HOMEPAGE="http://danfm.ca/emcee/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}"
+
+python_test() {
+ distutils_install_for_testing
+ ${EPYTHON} -c "import ${PN}; ${PN}.test()" 2>&1 | tee test.log || die
+ grep -Eq "^(ERROR|FAIL):" test.log && die
+}