aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/extension-helpers/extension-helpers-1.0.0.ebuild')
-rw-r--r--dev-python/extension-helpers/extension-helpers-1.0.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/extension-helpers/extension-helpers-1.0.0.ebuild b/dev-python/extension-helpers/extension-helpers-1.0.0.ebuild
new file mode 100644
index 000000000..4532642fa
--- /dev/null
+++ b/dev-python/extension-helpers/extension-helpers-1.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Utilities for building and installing packages in the Astropy ecosystem"
+HOMEPAGE="https://github.com/astropy/astropy-helpers"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+#TODO: Package all these pytest deps:
+# pytest-doctestplus>=0.2.0
+# pytest-remotedata>=0.3.1
+# pytest-openfiles>=0.3.1
+# pytest-astropy-header>=0.1.2
+# pytest-arraydiff>=0.1
+# pytest-filter-subpackage>=0.1
+RESTRICT="test"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinx-astropy