aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/fiona')
-rw-r--r--dev-python/fiona/Manifest2
-rw-r--r--dev-python/fiona/fiona-1.9.0.ebuild (renamed from dev-python/fiona/fiona-1.8.20.ebuild)18
2 files changed, 11 insertions, 9 deletions
diff --git a/dev-python/fiona/Manifest b/dev-python/fiona/Manifest
index 6f48f8721..bed2fa4ce 100644
--- a/dev-python/fiona/Manifest
+++ b/dev-python/fiona/Manifest
@@ -1 +1 @@
-DIST fiona-1.8.20.tar.gz 269491 BLAKE2B 0778a0824e3ecd70fc7a153a4be4631c04e70dc6218c3c78e7ddffae01db22a081f8f8b7f44cce37f864e32277b88596263d6ac640293c93e6a14ec7a932aa04 SHA512 4864f3c48903b34c6b4d2cf5dcdc5ebb6e155e32e7e138bdf17756a823f36a0985162c211127b283235569235c830e11abd330c229b2bb8de6cee053fe3204d7
+DIST fiona-1.9.0.gh.tar.gz 290797 BLAKE2B 1cd2a4a26d23d057433889937b4fecefb1e1585dc6b507e297ef3bab8cf72f734bc080bab8487d58c636312bca1330960f78fc2916d27c9a7247df087818c9b3 SHA512 f59d148cfc4f1cab6d89660146522920fab8b6fb1120ad8f3d3e8349d5fa823860984f8fd331e2fc3183a4a186a165508db8dcbcbdf4b943a7dad82d8d51d866
diff --git a/dev-python/fiona/fiona-1.8.20.ebuild b/dev-python/fiona/fiona-1.9.0.ebuild
index 1127afa70..7bc415b14 100644
--- a/dev-python/fiona/fiona-1.8.20.ebuild
+++ b/dev-python/fiona/fiona-1.9.0.ebuild
@@ -1,39 +1,38 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{10..11} )
DISTUTILS_USE_PEP517="setuptools"
inherit distutils-r1
DESCRIPTION="API for reading/writing vector geospatial data"
HOMEPAGE="https://github.com/Toblerity/fiona"
-SRC_URI="https://github.com/Toblerity/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/Toblerity/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/Fiona-${PV}"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="
- sci-libs/gdal[geos,sqlite,python,${PYTHON_USEDEP}]
+ sci-libs/gdal[geos,sqlite]
dev-python/attrs[${PYTHON_USEDEP}]
dev-python/click-plugins[${PYTHON_USEDEP}]
dev-python/cligj[${PYTHON_USEDEP}]
dev-python/munch[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
dev-python/certifi[${PYTHON_USEDEP}]
"
+
BDEPEND="
dev-python/cython[${PYTHON_USEDEP}]
test? (
dev-python/boto3[${PYTHON_USEDEP}]
- sci-libs/gdal[geos,sqlite,python,${PYTHON_USEDEP}]
+ sci-libs/gdal[geos,sqlite]
)
"
-S="${WORKDIR}/Fiona-${PV}"
-
distutils_enable_tests pytest
python_test() {
@@ -56,6 +55,9 @@ python_test() {
tests/test_drvsupport.py::test_no_append_driver_cannot_append[PCIDSK]
tests/test_drvsupport.py::test_write_or_driver_error[DGN]
+ # failure in flatgeobuf impl
+ tests/test_drvsupport.py::test_no_append_driver_cannot_append[FlatGeobuf]
+
# geos
#tests/test_collection.py::test_mask_polygon_triangle
#tests/test_collection.py::test_mask_polygon_triangle