aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/fscacher/fscacher-0.2.0.ebuild')
-rw-r--r--dev-python/fscacher/fscacher-0.2.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/fscacher/fscacher-0.2.0.ebuild b/dev-python/fscacher/fscacher-0.2.0.ebuild
new file mode 100644
index 000000000..f466d0675
--- /dev/null
+++ b/dev-python/fscacher/fscacher-0.2.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+inherit distutils-r1
+
+DESCRIPTION="Cache results of operations on heavy file trees"
+HOMEPAGE="https://github.com/con/fscacher"
+SRC_URI="https://github.com/con/fscacher/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/joblib[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.2.0-coverage.patch"
+)
+
+distutils_enable_tests pytest