aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/fslpy/fslpy-3.8.1.ebuild')
-rw-r--r--dev-python/fslpy/fslpy-3.8.1.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/fslpy/fslpy-3.8.1.ebuild b/dev-python/fslpy/fslpy-3.8.1.ebuild
deleted file mode 100644
index 5bff5ed60..000000000
--- a/dev-python/fslpy/fslpy-3.8.1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..9} )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="The FSL Python Library"
-HOMEPAGE="https://git.fmrib.ox.ac.uk/fsl/fslpy"
-SRC_URI="https://git.fmrib.ox.ac.uk/fsl/${PN}/-/archive/${PV}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- >=dev-python/h5py-2.9[${PYTHON_USEDEP}]
- >=dev-python/indexed_gzip-0.7.0[${PYTHON_USEDEP}]
- >=dev-python/numpy-1[${PYTHON_USEDEP}]
- >=dev-python/pillow-3.2.0[${PYTHON_USEDEP}]
- >=dev-python/trimesh-2.37.29[${PYTHON_USEDEP}]
- =dev-python/wxpython-4*[${PYTHON_USEDEP}]
- >=sci-libs/rtree-0.8.3[${PYTHON_USEDEP}]
- >=sci-libs/nibabel-2.4[${PYTHON_USEDEP}]
- >=dev-python/scipy-0.18[${PYTHON_USEDEP}]
-"
-
-PATCHES=(
- "${FILESDIR}/fslpy-2.7.0-coverage.patch"
-)
-
-distutils_enable_tests pytest
-distutils_enable_sphinx doc dev-python/sphinx_rtd_theme
-
-python_test() {
- virtx epytest --niters=50 -m "not (dicomtest or longtest or fsltest)"
-}