aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/geopandas')
-rw-r--r--dev-python/geopandas/Manifest2
-rw-r--r--dev-python/geopandas/geopandas-0.10.2.ebuild34
-rw-r--r--dev-python/geopandas/geopandas-0.13.2.ebuild42
-rw-r--r--dev-python/geopandas/metadata.xml30
4 files changed, 58 insertions, 50 deletions
diff --git a/dev-python/geopandas/Manifest b/dev-python/geopandas/Manifest
index c541ed559..037a125d3 100644
--- a/dev-python/geopandas/Manifest
+++ b/dev-python/geopandas/Manifest
@@ -1 +1 @@
-DIST geopandas-0.10.2.tar.gz 6317604 BLAKE2B 5eb0d84c11eda99b43bc15b179a971c5e56fb36d40c771b523161dd6ddac4faee4bac483ccd1bdb9f10f73dfd2adf6d72703cc180359cd68383bfba9410f4f5b SHA512 339660c423955b9f110eb390c3d1dc88eeb1ed74fa300870ae277d312e9b2e6733463bc45b445c73a9f8b6dee82d82f203c7b75c0a4aad7e36e43e5c7ec78f42
+DIST geopandas-0.13.2.gh.tar.gz 6388249 BLAKE2B 910f32ea7d798bbdeee77be190c57daf7bdc719901a2183b5328ec13619ff9b4145d1717afed8fc71da154d84f388ce2bc30c541478f95ed121c7d8681c691ae SHA512 4dff4bfeca2490081c02c41edf92037fa8a8f4b030b6f6a0cdc231b3119f829604af39277125db9535c66aac0698d2d4dcfac2bb58b92d31bea83f0ee296e21a
diff --git a/dev-python/geopandas/geopandas-0.10.2.ebuild b/dev-python/geopandas/geopandas-0.10.2.ebuild
deleted file mode 100644
index 6dde1c23f..000000000
--- a/dev-python/geopandas/geopandas-0.10.2.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_USE_PEP517="setuptools"
-inherit distutils-r1
-
-DESCRIPTION="Python tools for geographic data"
-HOMEPAGE="https://github.com/geopandas/geopandas"
-SRC_URI="https://github.com/geopandas/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/pandas[${PYTHON_USEDEP}]
- sci-libs/shapely[${PYTHON_USEDEP}]
- dev-python/fiona[${PYTHON_USEDEP}]
- dev-python/pyproj[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
-
-python_test() {
- local deselect=(
- # disable tests due to networking being blocked
- geopandas/io/tests/test_file.py::test_read_file_remote_zipfile_url
- geopandas/io/tests/test_file.py::test_read_file_remote_geojson_url
- )
-
- epytest ${deselect[@]/#/--deselect }
-}
diff --git a/dev-python/geopandas/geopandas-0.13.2.ebuild b/dev-python/geopandas/geopandas-0.13.2.ebuild
new file mode 100644
index 000000000..921c13417
--- /dev/null
+++ b/dev-python/geopandas/geopandas-0.13.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python tools for geographic data"
+HOMEPAGE="https://github.com/geopandas/geopandas https://pypi.org/project/geopandas/"
+SRC_URI="https://github.com/geopandas/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/shapely[${PYTHON_USEDEP}]
+ dev-python/fiona[${PYTHON_USEDEP}]
+ dev-python/pyproj[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # needs network access
+ geopandas/io/tests/test_file.py::test_read_file_url
+ # fails with RuntimeError thrown by matplotlib
+ geopandas/tests/test_plotting.py::TestGeoplotAccessor::test_pandas_kind
+ )
+
+ epytest ${deselect[@]/#/--deselect }
+}
+
+pkg_postinst() {
+ optfeature "plotting" dev-python/matplotlib
+ optfeature "spatial indexes and spatial joins" sci-libs/rtree
+ optfeature "geocoding" sci-geosciences/geopy
+ optfeature "geodatabase access" dev-python/psycopg dev-python/sqlalchemy
+}
diff --git a/dev-python/geopandas/metadata.xml b/dev-python/geopandas/metadata.xml
index a9b62a0d8..a102c7148 100644
--- a/dev-python/geopandas/metadata.xml
+++ b/dev-python/geopandas/metadata.xml
@@ -1,19 +1,19 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
- </maintainer>
- <longdescription lang="en">
- GeoPandas is a project to add support for geographic data to pandas
- objects. It currently implements GeoSeries and GeoDataFrame types
- which are subclasses of pandas.Series and pandas.DataFrame
- respectively. GeoPandas objects can act on shapely geometry objects
- and perform geometric operations.
-</longdescription>
- <upstream>
- <remote-id type="github">geopandas/geopandas</remote-id>
- <remote-id type="pypi">geopandas</remote-id>
- </upstream>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ GeoPandas is a project to add support for geographic data to pandas
+ objects. It currently implements GeoSeries and GeoDataFrame types
+ which are subclasses of pandas.Series and pandas.DataFrame
+ respectively. GeoPandas objects can act on shapely geometry objects
+ and perform geometric operations.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">geopandas/geopandas</remote-id>
+ <remote-id type="pypi">geopandas</remote-id>
+ </upstream>
</pkgmetadata>