aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/gmsh_interop/gmsh_interop-2021.1.1.ebuild')
-rw-r--r--dev-python/gmsh_interop/gmsh_interop-2021.1.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/gmsh_interop/gmsh_interop-2021.1.1.ebuild b/dev-python/gmsh_interop/gmsh_interop-2021.1.1.ebuild
new file mode 100644
index 000000000..3185102ba
--- /dev/null
+++ b/dev-python/gmsh_interop/gmsh_interop-2021.1.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_10 )
+inherit distutils-r1 pypi
+
+DESCRIPTION="Interoperability with Gmsh for Python"
+HOMEPAGE="https://github.com/inducer/gmsh_interop/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-python/numpy-1.6.0[${PYTHON_USEDEP}]
+ dev-python/pytools[${PYTHON_USEDEP}]
+ sci-libs/gmsh[blas]
+"
+BDEPEND="
+ test? (
+ dev-python/joblib[${PYTHON_USEDEP}]
+ )
+"
+distutils_enable_tests pytest