aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/google-cloud-storage/google-cloud-storage-2.7.0.ebuild')
-rw-r--r--dev-python/google-cloud-storage/google-cloud-storage-2.7.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/google-cloud-storage/google-cloud-storage-2.7.0.ebuild b/dev-python/google-cloud-storage/google-cloud-storage-2.7.0.ebuild
new file mode 100644
index 000000000..403f75dee
--- /dev/null
+++ b/dev-python/google-cloud-storage/google-cloud-storage-2.7.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google Cloud Storage API client library"
+HOMEPAGE="https://github.com/googleapis/python-storage"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/google-auth[${PYTHON_USEDEP}]
+ dev-python/google-api-core[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest