aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/hdf5storage/hdf5storage-9999.ebuild')
-rw-r--r--dev-python/hdf5storage/hdf5storage-9999.ebuild26
1 files changed, 19 insertions, 7 deletions
diff --git a/dev-python/hdf5storage/hdf5storage-9999.ebuild b/dev-python/hdf5storage/hdf5storage-9999.ebuild
index 194a845ce..1bcf35a57 100644
--- a/dev-python/hdf5storage/hdf5storage-9999.ebuild
+++ b/dev-python/hdf5storage/hdf5storage-9999.ebuild
@@ -1,14 +1,24 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
+EAPI=8
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1 git-r3
+inherit distutils-r1
DESCRIPTION="Read/write Python types to/from HDF5 files, including MATLAB v7.3 MAT files"
HOMEPAGE="https://github.com/frejanordsiek/hdf5storage"
-EGIT_REPO_URI="https://github.com/frejanordsiek/${PN}.git git://github.com/frejanordsiek/${PN}.git"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/frejanordsiek/hdf5storage"
+else
+ COMMIT=09dfc5fb3a6a3f9c32c2479a896c7f14d3c8d830
+ SRC_URI="https://github.com/frejanordsiek/hdf5storage/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${COMMIT}
+ KEYWORDS="~amd64"
+fi
LICENSE="BSD"
SLOT="0"
@@ -16,5 +26,7 @@ SLOT="0"
RDEPEND="
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/h5py[${PYTHON_USEDEP}]
- "
-DEPEND="${RDEPEND}" \ No newline at end of file
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest