aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/heudiconv')
-rw-r--r--dev-python/heudiconv/Manifest2
-rw-r--r--dev-python/heudiconv/heudiconv-0.13.0.ebuild42
-rw-r--r--dev-python/heudiconv/heudiconv-1.0.0.ebuild42
-rw-r--r--dev-python/heudiconv/metadata.xml16
4 files changed, 102 insertions, 0 deletions
diff --git a/dev-python/heudiconv/Manifest b/dev-python/heudiconv/Manifest
new file mode 100644
index 000000000..fe38a3307
--- /dev/null
+++ b/dev-python/heudiconv/Manifest
@@ -0,0 +1,2 @@
+DIST heudiconv-0.13.0.tar.gz 9158053 BLAKE2B 9f87fbcd5ea8ccca39cc029f1bdd84906412a22e5d18e2afe280d19737f0dda4c03248ba93f58c06aae4b15366477e8a5d1c41d09d1b1d3a10ff673aaa050e26 SHA512 b867ee0a60ad98099a3802e290ebb24b858befbd45e93772fafe437a87ea867c5076680ea3ed7856272397267c740ef2eade9f64ffc0d4216d4a37be39add158
+DIST heudiconv-1.0.0.tar.gz 9158631 BLAKE2B af5b3dee2448a025a231fad0ac9692b13d431288ea0ca19b4919d9ae83c86a7c72cf11f9bd3a0ec6b18259d2f8e8cecf9372a0fae605ecb5e9cac0bd4975693a SHA512 165bd814e3c7f25b51ed8884bddde45b82dc226ee93af5984b822aa53ad5e7504aae57088cd1f777c62835669e8816d95dbf84de7fb379038308dca7871d8739
diff --git a/dev-python/heudiconv/heudiconv-0.13.0.ebuild b/dev-python/heudiconv/heudiconv-0.13.0.ebuild
new file mode 100644
index 000000000..7f7db0b0e
--- /dev/null
+++ b/dev-python/heudiconv/heudiconv-0.13.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="Flexible DICOM conversion to structured directory layouts"
+HOMEPAGE="
+ https://github.com/nipy/heudiconv
+ https://heudiconv.readthedocs.io/en/latest/
+"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-python/versioningit[${PYTHON_USEDEP}]
+ sci-biology/dcm2niix
+ sci-biology/dcmstack[${PYTHON_USEDEP}]
+ sci-libs/nibabel[${PYTHON_USEDEP}]
+ sci-libs/nipype[${PYTHON_USEDEP}]
+ sci-libs/pydicom[${PYTHON_USEDEP}]
+ "
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+# Reported upstream:
+# https://github.com/nipy/heudiconv/issues/679
+EPYTEST_DESELECT=(
+ heudiconv/tests/test_main.py::test_prepare_for_datalad
+)
+
+distutils_enable_tests pytest
diff --git a/dev-python/heudiconv/heudiconv-1.0.0.ebuild b/dev-python/heudiconv/heudiconv-1.0.0.ebuild
new file mode 100644
index 000000000..7f7db0b0e
--- /dev/null
+++ b/dev-python/heudiconv/heudiconv-1.0.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="Flexible DICOM conversion to structured directory layouts"
+HOMEPAGE="
+ https://github.com/nipy/heudiconv
+ https://heudiconv.readthedocs.io/en/latest/
+"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-python/versioningit[${PYTHON_USEDEP}]
+ sci-biology/dcm2niix
+ sci-biology/dcmstack[${PYTHON_USEDEP}]
+ sci-libs/nibabel[${PYTHON_USEDEP}]
+ sci-libs/nipype[${PYTHON_USEDEP}]
+ sci-libs/pydicom[${PYTHON_USEDEP}]
+ "
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+# Reported upstream:
+# https://github.com/nipy/heudiconv/issues/679
+EPYTEST_DESELECT=(
+ heudiconv/tests/test_main.py::test_prepare_for_datalad
+)
+
+distutils_enable_tests pytest
diff --git a/dev-python/heudiconv/metadata.xml b/dev-python/heudiconv/metadata.xml
new file mode 100644
index 000000000..a98cbf459
--- /dev/null
+++ b/dev-python/heudiconv/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@chymera.eu</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">heudiconv</remote-id>
+ <remote-id type="github">nipy/heudiconv</remote-id>
+ </upstream>
+</pkgmetadata>