aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/hist/hist-2.7.2.ebuild')
-rw-r--r--dev-python/hist/hist-2.7.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/hist/hist-2.7.2.ebuild b/dev-python/hist/hist-2.7.2.ebuild
new file mode 100644
index 000000000..082844a5f
--- /dev/null
+++ b/dev-python/hist/hist-2.7.2.ebuild
@@ -0,0 +1,26 @@
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=hatchling
+SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+inherit distutils-r1 pypi
+
+DESCRIPTION="Histogramming for analysis powered by boost-histogram "
+HOMEPAGE="https://github.com/scikit-hep/hist"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/boost-histogram-1.3.1[${PYTHON_USEDEP}]
+ >=dev-python/histoprint-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.14.5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+RESTRICT="test"
+# needs mplhep and dask_histogram ...
+#distutils_enable_tests pytest