aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/histoprint/histoprint-2.4.0.ebuild')
-rw-r--r--dev-python/histoprint/histoprint-2.4.0.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/histoprint/histoprint-2.4.0.ebuild b/dev-python/histoprint/histoprint-2.4.0.ebuild
new file mode 100644
index 000000000..b6395b898
--- /dev/null
+++ b/dev-python/histoprint/histoprint-2.4.0.ebuild
@@ -0,0 +1,20 @@
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pretty print histograms to the console"
+HOMEPAGE="https://github.com/scikit-hep/histoprint"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/click-7.0.0[${PYTHON_USEDEP}]
+ >=dev-python/uhi-0.2.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest