aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ipyparallel/ipyparallel-4.0.2-r1.ebuild')
-rw-r--r--dev-python/ipyparallel/ipyparallel-4.0.2-r1.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/dev-python/ipyparallel/ipyparallel-4.0.2-r1.ebuild b/dev-python/ipyparallel/ipyparallel-4.0.2-r1.ebuild
deleted file mode 100644
index be83c50bd..000000000
--- a/dev-python/ipyparallel/ipyparallel-4.0.2-r1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Interactive Parallel Computing with IPython"
-HOMEPAGE="http://ipython.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-RDEPEND="
- dev-python/ipython_genutils[${PYTHON_USEDEP}]
- dev-python/decorator[${PYTHON_USEDEP}]
- >=dev-python/pyzmq-14.4.0[${PYTHON_USEDEP}]
- dev-python/ipykernel[${PYTHON_USEDEP}]
- !<dev-python/ipython-4.0.0[smp]
- >=dev-python/ipython-4.0.0[${PYTHON_USEDEP}]
- dev-python/jupyter_client[${PYTHON_USEDEP}]
- "
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- )
- "
-
-python_prepare_all() {
- # Prevent un-needed download during build
- if use doc; then
- sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- iptest --coverage xml ipyparallel.tests || die
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( docs/build/html/. )
- distutils-r1_python_install_all
-}