aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/meshpy/meshpy-2018.2.1.ebuild')
-rw-r--r--dev-python/meshpy/meshpy-2018.2.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/meshpy/meshpy-2018.2.1.ebuild b/dev-python/meshpy/meshpy-2018.2.1.ebuild
new file mode 100644
index 000000000..5df9336ad
--- /dev/null
+++ b/dev-python/meshpy/meshpy-2018.2.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_IN_SOURCE_BUILD=1
+PYTHON_COMPAT=( python3_{6..8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Quality triangular and tetrahedral mesh generation for Python"
+HOMEPAGE="https://mathema.tician.de/software/meshpy
+ https://pypi.python.org/pypi/MeshPy
+"
+
+SRC_URI="https://github.com/inducer/meshpy/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-libs/boost[python,${PYTHON_USEDEP}]
+ dev-python/gmsh_interop[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pybind11[${PYTHON_USEDEP}]
+ dev-python/pytools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ sci-libs/gmsh
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed 's:delay=10:delay=1:g' -i aksetup_helper.py || die
+
+# echo "BOOST_PYTHON_LIBNAME = ['boost_${EPYTHON}-mt']">> "${S}"/siteconf.py
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv || die "tests failed with ${EPYTHON}"
+}