aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/numarray/numarray-1.5.1-r1.ebuild')
-rw-r--r--dev-python/numarray/numarray-1.5.1-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/numarray/numarray-1.5.1-r1.ebuild b/dev-python/numarray/numarray-1.5.1-r1.ebuild
new file mode 100644
index 000000000..c6b71a248
--- /dev/null
+++ b/dev-python/numarray/numarray-1.5.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit distutils
+
+DESCRIPTION="Large array processing extension module for Python"
+SRC_URI="mirror://sourceforge/numpy/${P}.tar.gz"
+HOMEPAGE="http://www.stsci.edu/resources/software_hardware/numarray"
+# force blas-atlas because we don't have a virtual/cblas
+DEPEND=">=dev-lang/python-2.3
+ lapack? ( sci-libs/blas-atlas )
+ lapack? ( virtual/lapack )"
+IUSE="lapack"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="BSD"
+
+src_compile() {
+
+ local myconf="--genapi"
+ if use lapack; then
+ sed -i cfg_packages.py \
+ -e 's:/usr/local/lib/atlas:/usr/lib/blas/atlas:g' \
+ -e 's:/usr/local/include/atlas:/usr/include/atlas:g' \
+ -e 's:f77blas:blas:g'
+ myconf="${myconf} --use_lapack"
+ fi
+ python setup.py build ${myconf} || die "build failed"
+}
+
+src_test() {
+ einfo "Testing installation ..."
+ python -c "import numarray.testall as nt; nt.test()" || \
+ die "test failed!"
+}
+
+src_install() {
+ distutils_src_install
+ dodoc Doc/*.txt LICENSE.txt
+ cp -r Doc/*.py Doc/manual Doc/release_notes Examples ${D}/usr/share/doc/${PF}
+}