aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/nwbinspector/nwbinspector-0.4.19.ebuild')
-rw-r--r--dev-python/nwbinspector/nwbinspector-0.4.19.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/nwbinspector/nwbinspector-0.4.19.ebuild b/dev-python/nwbinspector/nwbinspector-0.4.19.ebuild
new file mode 100644
index 000000000..b4b5f7448
--- /dev/null
+++ b/dev-python/nwbinspector/nwbinspector-0.4.19.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+inherit distutils-r1
+
+DESCRIPTION="Inspect NWB files for compliance with NWB Best Practices"
+HOMEPAGE="https://github.com/NeurodataWithoutBorders/nwbinspector"
+SRC_URI="https://github.com/NeurodataWithoutBorders/nwbinspector/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND=""
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/natsort[${PYTHON_USEDEP}]
+ dev-python/pynwb[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+"
+BDEPEND=""
+
+distutils_enable_tests pytest