aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/palettable/palettable-3.3.0.ebuild')
-rw-r--r--dev-python/palettable/palettable-3.3.0.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/dev-python/palettable/palettable-3.3.0.ebuild b/dev-python/palettable/palettable-3.3.0.ebuild
deleted file mode 100644
index 1288d9233..000000000
--- a/dev-python/palettable/palettable-3.3.0.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="library of color palettes for python"
-HOMEPAGE="https://github.com/jiffyclub/palettable"
-
-if [ ${PV} == "9999" ] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/jiffyclub/palettable.git"
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-
-RDEPEND="
- ${PYTHON_DEPS}
- dev-python/matplotlib[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-
-distutils_enable_tests pytest
-
-python_test() {
- distutils_install_for_testing
- pytest -vv || die "tests failed for ${EPYTHON}"
-}