aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pamela')
-rw-r--r--dev-python/pamela/Manifest1
-rw-r--r--dev-python/pamela/metadata.xml16
-rw-r--r--dev-python/pamela/pamela-0.2.1.ebuild15
-rw-r--r--dev-python/pamela/pamela-9999.ebuild22
4 files changed, 0 insertions, 54 deletions
diff --git a/dev-python/pamela/Manifest b/dev-python/pamela/Manifest
deleted file mode 100644
index 09a551427..000000000
--- a/dev-python/pamela/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST pamela-0.2.1.tar.gz 5314 BLAKE2B acfcd678a6fd5e6ae8e9a1cce4a3dfdf1dc0d923704e550f09cbac40e37ef7afd10250eebaf50010acc13dcdc87c4500b73188666a30a7b9f03c3c49b6617474 SHA512 c0393c7f6d1d8cb257d025577fda3ae0c5839a32cd0748210d298df1745466afebb0e917498440c7550d0a0f0437b908ef712080fb02aa0a1b4c9d3d29cbdf07
diff --git a/dev-python/pamela/metadata.xml b/dev-python/pamela/metadata.xml
deleted file mode 100644
index e458bccf6..000000000
--- a/dev-python/pamela/metadata.xml
+++ /dev/null
@@ -1,16 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
- </maintainer>
- <longdescription>
-An interface to the Pluggable Authentication Modules (PAM) library,
-written in pure Python (using ctypes).
-</longdescription>
- <upstream>
- <remote-id type="github">minrk/pamela</remote-id>
- <remote-id type="pypi">pamela</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/pamela/pamela-0.2.1.ebuild b/dev-python/pamela/pamela-0.2.1.ebuild
deleted file mode 100644
index 307894d13..000000000
--- a/dev-python/pamela/pamela-0.2.1.ebuild
+++ /dev/null
@@ -1,15 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
-
-inherit distutils-r1
-
-DESCRIPTION="PAM interface using ctypes"
-HOMEPAGE="https://github.com/minrk/pamela"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-KEYWORDS="~amd64"
-
-LICENSE="MIT"
-SLOT="0"
diff --git a/dev-python/pamela/pamela-9999.ebuild b/dev-python/pamela/pamela-9999.ebuild
deleted file mode 100644
index 6450b7e24..000000000
--- a/dev-python/pamela/pamela-9999.ebuild
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
-
-inherit distutils-r1 git-r3
-
-DESCRIPTION="PAM interface using ctypes"
-HOMEPAGE="https://github.com/minrk/pamela"
-EGIT_REPO_URI="https://github.com/minrk/${PN}.git git://github.com/minrk/${PN}.git"
-KEYWORDS=""
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="test"
-
-DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-python_test() {
- py.test --assert=plain test_pamela.py
-}