aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pandas-stubs')
-rw-r--r--dev-python/pandas-stubs/Manifest1
-rw-r--r--dev-python/pandas-stubs/metadata.xml16
-rw-r--r--dev-python/pandas-stubs/pandas-stubs-2.1.1.230928.ebuild52
3 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/pandas-stubs/Manifest b/dev-python/pandas-stubs/Manifest
new file mode 100644
index 000000000..856ff2fe2
--- /dev/null
+++ b/dev-python/pandas-stubs/Manifest
@@ -0,0 +1 @@
+DIST pandas-stubs-2.1.1.230928.gh.tar.gz 192865 BLAKE2B f3604def27a3ba7444969473c5800f7cc72fd4487f2363f326de6d637f1b6b60d2a8707f6cbb2647389691fbd856a2e7e5cf3710c0ad014ae106472c76dfb1c8 SHA512 5f9e71f187d1532388a98e0139852098c00d44d3ddf32fc3bad1c5199291c7dd4af82b2d73605b1e16b09a79f3b9df02752b37cf87fcb222faee9e704f52dd47
diff --git a/dev-python/pandas-stubs/metadata.xml b/dev-python/pandas-stubs/metadata.xml
new file mode 100644
index 000000000..8cbc804ad
--- /dev/null
+++ b/dev-python/pandas-stubs/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Gentoo Python Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>gentoo@chymera.eu</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pandas-dev/pandas-stubs</remote-id>
+ <remote-id type="pypi">pandas-stubs</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pandas-stubs/pandas-stubs-2.1.1.230928.ebuild b/dev-python/pandas-stubs/pandas-stubs-2.1.1.230928.ebuild
new file mode 100644
index 000000000..e10fd1aca
--- /dev/null
+++ b/dev-python/pandas-stubs/pandas-stubs-2.1.1.230928.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..11} )
+inherit distutils-r1
+
+DESCRIPTION="Public type stubs for pandas"
+HOMEPAGE="https://github.com/pandas-dev/pandas-stubs"
+SRC_URI="https://github.com/pandas-dev/pandas-stubs/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+# Allegedly also needs dev-python/types-pytz (available in ::guru), but somehow works without it...
+# https://github.com/pandas-dev/pandas-stubs/blob/3c2affdaeb1cb03777cc59832dcdd4b030add27d/pyproject.toml#L34
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/xarray[${PYTHON_USEDEP}]
+ dev-python/pyarrow[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # Package has a bunch of test deps missing from ::gentoo and ::science
+ tests/test_frame.py::test_to_markdown
+ tests/test_frame.py::test_types_to_feather
+ tests/test_io.py::test_orc
+ tests/test_io.py::test_orc_path
+ tests/test_io.py::test_orc_buffer
+ tests/test_io.py::test_orc_columns
+ tests/test_io.py::test_orc_bytes
+ tests/test_io.py::test_hdf
+ tests/test_io.py::test_hdfstore
+ tests/test_io.py::test_read_hdf_iterator
+ tests/test_io.py::test_hdf_context_manager
+ tests/test_io.py::test_hdf_series
+ tests/test_io.py::test_spss
+ tests/test_io.py::test_parquet
+ tests/test_io.py::test_parquet_options
+ tests/test_io.py::test_excel_writer_engine
+ tests/test_io.py::test_all_read_without_lxml_dtype_backend
+ tests/test_series.py::test_types_agg
+ tests/test_series.py::test_types_aggregate
+)
+
+distutils_enable_tests pytest