aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/param/param-1.10.1.ebuild')
-rw-r--r--dev-python/param/param-1.10.1.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/dev-python/param/param-1.10.1.ebuild b/dev-python/param/param-1.10.1.ebuild
index 3be942fe3..8e8ec8053 100644
--- a/dev-python/param/param-1.10.1.ebuild
+++ b/dev-python/param/param-1.10.1.ebuild
@@ -1,16 +1,22 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1
DESCRIPTION="Make Python code clearer and more reliable by declaring Parameters"
HOMEPAGE="https://param.holoviz.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+# Pypi sources do not include tests
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/holoviz/param/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
LICENSE="BSD"
KEYWORDS="~amd64 ~x86"
SLOT="0"
+
+# Some tests require nose:
+#distutils_enable_tests unittest