aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/param/param-1.12.3.ebuild')
-rw-r--r--dev-python/param/param-1.12.3.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/param/param-1.12.3.ebuild b/dev-python/param/param-1.12.3.ebuild
new file mode 100644
index 000000000..9ce9e3762
--- /dev/null
+++ b/dev-python/param/param-1.12.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Make Python code clearer and more reliable by declaring Parameters"
+HOMEPAGE="https://param.holoviz.org"
+# Pypi sources do not include tests, reported upstream:
+# https://github.com/holoviz/param/issues/678
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/holoviz/param/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+distutils_enable_tests pytest