aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/persim/persim-0.3.1.ebuild')
-rw-r--r--dev-python/persim/persim-0.3.1.ebuild32
1 files changed, 25 insertions, 7 deletions
diff --git a/dev-python/persim/persim-0.3.1.ebuild b/dev-python/persim/persim-0.3.1.ebuild
index 6e1d989aa..994dca206 100644
--- a/dev-python/persim/persim-0.3.1.ebuild
+++ b/dev-python/persim/persim-0.3.1.ebuild
@@ -1,21 +1,21 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1
+inherit distutils-r1 pypi
DESCRIPTION="Distances and representations of persistence diagrams"
HOMEPAGE="https://persim.scikit-tda.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64"
-RDEPEND="${PYTHON_DEPS}
+RDEPEND="
dev-python/hopcroftkarp[${PYTHON_USEDEP}]
dev-python/matplotlib[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
@@ -26,3 +26,21 @@ RDEPEND="${PYTHON_DEPS}
BDEPEND="test? ( dev-python/deprecated[${PYTHON_USEDEP}] )"
distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Reported upsream:
+ # https://github.com/scikit-tda/persim/issues/66
+ test/test_landscapes.py::TestPersLandscapeExact::test_exact_critical_pairs
+ test/test_persim.py::test_integer_diagrams
+ test/test_persim.py::TestEmpty::test_empyt_diagram_list
+ test/test_persim.py::TestTransforms::test_lists_of_lists
+ test/test_persim.py::TestTransforms::test_n_pixels
+ test/test_persim.py::TestTransforms::test_multiple_diagrams
+ test/test_persistence_imager.py::test_empty_diagram_list
+ test/test_persistence_imager.py::test_fit_diagram
+ test/test_persistence_imager.py::test_fit_diagram_list
+ test/test_persistence_imager.py::test_mixed_pairs
+ test/test_persistence_imager.py::TestTransformOutput::test_lists_of_lists
+ test/test_persistence_imager.py::TestTransformOutput::test_n_pixels
+ test/test_persistence_imager.py::TestTransformOutput::test_multiple_diagrams
+)