aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pickleshare/pickleshare-9999.ebuild')
-rw-r--r--dev-python/pickleshare/pickleshare-9999.ebuild29
1 files changed, 0 insertions, 29 deletions
diff --git a/dev-python/pickleshare/pickleshare-9999.ebuild b/dev-python/pickleshare/pickleshare-9999.ebuild
deleted file mode 100644
index 95306c174..000000000
--- a/dev-python/pickleshare/pickleshare-9999.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
-
-inherit distutils-r1 git-r3
-
-DESCRIPTION="A small 'shelve' like datastore with concurrency support"
-HOMEPAGE="https://github.com/pickleshare/pickleshare"
-EGIT_REPO_URI="https://github.com/${PN}/${PN}.git git://github.com/${PN}/${PN}.git"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS=""
-IUSE="test"
-
-RDEPEND="
- dev-python/path-py[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-python_test() {
- distutils_install_for_testing
- cd "${TEST_DIR}"/lib || die
- cp "${S}"/test_pickleshare.py "${TEST_DIR}"/lib/ || die
- py.test || die
-}