aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/plac')
-rw-r--r--dev-python/plac/Manifest1
-rw-r--r--dev-python/plac/metadata.xml16
-rw-r--r--dev-python/plac/plac-1.4.2.ebuild23
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/plac/Manifest b/dev-python/plac/Manifest
new file mode 100644
index 000000000..f50e462dc
--- /dev/null
+++ b/dev-python/plac/Manifest
@@ -0,0 +1 @@
+DIST plac-1.4.2.tar.gz 37595 BLAKE2B 5205e9d8a5a775eb2e23ea7ad30e576417a8ba944cb196ccb7a16b514b6c4902856a7191b1bbf71ab0176910b5d8dc163ab36fe3fb0c5bb5765c02d16ae347b1 SHA512 c8c320cabda42f33071d7675b64befab8344bde746d0befe661a9bb26f658559435d2895dad0a27dc1d7c2dc59f07a359b529880e115d900b4fca8f245186742
diff --git a/dev-python/plac/metadata.xml b/dev-python/plac/metadata.xml
new file mode 100644
index 000000000..98f0f918b
--- /dev/null
+++ b/dev-python/plac/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mschu.dev@gmail.com</email>
+ <name>Michael Schubert</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ialbert/plac</remote-id>
+ <remote-id type="pypi">plac</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/plac/plac-1.4.2.ebuild b/dev-python/plac/plac-1.4.2.ebuild
new file mode 100644
index 000000000..50b269f42
--- /dev/null
+++ b/dev-python/plac/plac-1.4.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit pypi distutils-r1
+
+DESCRIPTION="Parsing the Command Line the Easy Way"
+HOMEPAGE="https://pypi.org/project/plac/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+EPYTEST_DESELECT=(
+ # Missing index.rst
+ doc/test_plac.py::test_doctest
+)
+
+distutils_enable_tests pytest