aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/probeinterface')
-rw-r--r--dev-python/probeinterface/Manifest3
-rw-r--r--dev-python/probeinterface/metadata.xml15
-rw-r--r--dev-python/probeinterface/probeinterface-0.2.14.ebuild37
-rw-r--r--dev-python/probeinterface/probeinterface-0.2.16.ebuild37
-rw-r--r--dev-python/probeinterface/probeinterface-0.2.20.ebuild37
5 files changed, 129 insertions, 0 deletions
diff --git a/dev-python/probeinterface/Manifest b/dev-python/probeinterface/Manifest
new file mode 100644
index 000000000..189bbfcaf
--- /dev/null
+++ b/dev-python/probeinterface/Manifest
@@ -0,0 +1,3 @@
+DIST probeinterface-0.2.14.gh.tar.gz 210232 BLAKE2B 5a2c4fb5bc0f1315777a70b4292a30b135022e3a70608584070088c5ff42b0e1474714472a306196b390e103b45eea70cb89e01cc5dca90b0c31ac4f44810c24 SHA512 e0f5cf5b6560f8c4e578cab708308c36ecf81446c0db684b520e1436e864f2f4e0dce0015461c7cfcba19a0c1c54345b2d55b972de5f4338b02b90731cff52c2
+DIST probeinterface-0.2.16.gh.tar.gz 302386 BLAKE2B e2124774f2f50779f1dc67b682085d87691c935909ab81591f005abd756c0925837b97e97bf651e2a84e2276f57bf6fd1df6de6289431b16227dc9caa6cea51c SHA512 7c38534dbcab837df1289074db054e31c0768bceefafeb6d70051f88a6ac289d664d77cd6c456f40e7c52a7b60a09e80a4a4fe5e8f491121157b0bbb4d5c1f84
+DIST probeinterface-0.2.20.gh.tar.gz 1930434 BLAKE2B 0087f82f8cea3e1eb225ba188487eb3862de8444cadb0cf76ebba1046f194eb1f369bab7b3ff35eb6b99c054409b902c1907037d42aa84d0d4253a47fa6009ce SHA512 16cee1845d4cd40f1bfdea654fff99ea5949fbd8606ffc038ea0ca27d6a4f3faa65e2dd448bcda1066c0d2984ce7e3995a0ead028ef57ae59743c34c6c5a4c39
diff --git a/dev-python/probeinterface/metadata.xml b/dev-python/probeinterface/metadata.xml
new file mode 100644
index 000000000..58f800ce0
--- /dev/null
+++ b/dev-python/probeinterface/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@chymera.eu</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">SpikeInterface/probeinterface</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/probeinterface/probeinterface-0.2.14.ebuild b/dev-python/probeinterface/probeinterface-0.2.14.ebuild
new file mode 100644
index 000000000..75dd43bd4
--- /dev/null
+++ b/dev-python/probeinterface/probeinterface-0.2.14.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+inherit distutils-r1
+
+DESCRIPTION="Python package to handle probe layout, geometry and wiring to device"
+HOMEPAGE="https://github.com/SpikeInterface/probeinterface"
+SRC_URI="https://github.com/SpikeInterface/probeinterface/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+# upstream doesn't pus test dir to pypi, https://github.com/SpikeInterface/probeinterface/issues/145
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # Requires network access:
+ # https://github.com/SpikeInterface/probeinterface/issues/70
+ tests/test_library.py::test_download_probeinterface_file
+ tests/test_library.py::test_get_from_cache
+ tests/test_library.py::test_get_probe
+ tests/test_wiring.py::test_wire_probe
+)
+distutils_enable_tests pytest
diff --git a/dev-python/probeinterface/probeinterface-0.2.16.ebuild b/dev-python/probeinterface/probeinterface-0.2.16.ebuild
new file mode 100644
index 000000000..75dd43bd4
--- /dev/null
+++ b/dev-python/probeinterface/probeinterface-0.2.16.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+inherit distutils-r1
+
+DESCRIPTION="Python package to handle probe layout, geometry and wiring to device"
+HOMEPAGE="https://github.com/SpikeInterface/probeinterface"
+SRC_URI="https://github.com/SpikeInterface/probeinterface/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+# upstream doesn't pus test dir to pypi, https://github.com/SpikeInterface/probeinterface/issues/145
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # Requires network access:
+ # https://github.com/SpikeInterface/probeinterface/issues/70
+ tests/test_library.py::test_download_probeinterface_file
+ tests/test_library.py::test_get_from_cache
+ tests/test_library.py::test_get_probe
+ tests/test_wiring.py::test_wire_probe
+)
+distutils_enable_tests pytest
diff --git a/dev-python/probeinterface/probeinterface-0.2.20.ebuild b/dev-python/probeinterface/probeinterface-0.2.20.ebuild
new file mode 100644
index 000000000..75dd43bd4
--- /dev/null
+++ b/dev-python/probeinterface/probeinterface-0.2.20.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+inherit distutils-r1
+
+DESCRIPTION="Python package to handle probe layout, geometry and wiring to device"
+HOMEPAGE="https://github.com/SpikeInterface/probeinterface"
+SRC_URI="https://github.com/SpikeInterface/probeinterface/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+# upstream doesn't pus test dir to pypi, https://github.com/SpikeInterface/probeinterface/issues/145
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # Requires network access:
+ # https://github.com/SpikeInterface/probeinterface/issues/70
+ tests/test_library.py::test_download_probeinterface_file
+ tests/test_library.py::test_get_from_cache
+ tests/test_library.py::test_get_probe
+ tests/test_wiring.py::test_wire_probe
+)
+distutils_enable_tests pytest