aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/protobuf-python')
-rw-r--r--dev-python/protobuf-python/Manifest1
-rw-r--r--dev-python/protobuf-python/files/protobuf-python-3.13.0-google.protobuf.pyext._message.PyUnknownFieldRef.patch22
-rw-r--r--dev-python/protobuf-python/metadata.xml8
-rw-r--r--dev-python/protobuf-python/protobuf-python-3.11.4-r1.ebuild59
4 files changed, 0 insertions, 90 deletions
diff --git a/dev-python/protobuf-python/Manifest b/dev-python/protobuf-python/Manifest
deleted file mode 100644
index 81632cac5..000000000
--- a/dev-python/protobuf-python/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST protobuf-3.11.4.tar.gz 5140799 BLAKE2B 97b450c0623593efe6a42b66582ff183344b8831689e6a5b4d36096dbd57c33da9569bbf26578536aaf73ecd866ac0588b6cb7d55a6a9b9a6e840d4c57099001 SHA512 777bbb0e9e2375eaebe6b8c87abd660bac70ee469c9ad00dd25917b82d7fb5bbe33cf87f0d69c90e19d55c07a7285ec20974ba4768623ce9ccfadf147fd5e261
diff --git a/dev-python/protobuf-python/files/protobuf-python-3.13.0-google.protobuf.pyext._message.PyUnknownFieldRef.patch b/dev-python/protobuf-python/files/protobuf-python-3.13.0-google.protobuf.pyext._message.PyUnknownFieldRef.patch
deleted file mode 100644
index 68318320b..000000000
--- a/dev-python/protobuf-python/files/protobuf-python-3.13.0-google.protobuf.pyext._message.PyUnknownFieldRef.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-https://github.com/protocolbuffers/protobuf/issues/6205
-https://github.com/protocolbuffers/protobuf/pull/7016
-
---- /python/google/protobuf/pyext/unknown_fields.cc
-+++ /python/google/protobuf/pyext/unknown_fields.cc
-@@ -277,13 +277,13 @@
- PyObject* data = NULL;
- switch (field->type()) {
- case UnknownField::TYPE_VARINT:
-- data = PyInt_FromLong(field->varint());
-+ data = PyLong_FromUnsignedLongLong(field->varint());
- break;
- case UnknownField::TYPE_FIXED32:
-- data = PyInt_FromLong(field->fixed32());
-+ data = PyLong_FromUnsignedLong(field->fixed32());
- break;
- case UnknownField::TYPE_FIXED64:
-- data = PyInt_FromLong(field->fixed64());
-+ data = PyLong_FromUnsignedLongLong(field->fixed64());
- break;
- case UnknownField::TYPE_LENGTH_DELIMITED:
- data = PyBytes_FromStringAndSize(field->length_delimited().data(),
diff --git a/dev-python/protobuf-python/metadata.xml b/dev-python/protobuf-python/metadata.xml
deleted file mode 100644
index 0d125ed97..000000000
--- a/dev-python/protobuf-python/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <description>Gentoo Science Project</description>
- </maintainer>
-</pkgmetadata>
diff --git a/dev-python/protobuf-python/protobuf-python-3.11.4-r1.ebuild b/dev-python/protobuf-python/protobuf-python-3.11.4-r1.ebuild
deleted file mode 100644
index 1d447ef46..000000000
--- a/dev-python/protobuf-python/protobuf-python-3.11.4-r1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 2008-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-PYTHON_COMPAT=(python{3_7,3_8})
-DISTUTILS_USE_SETUPTOOLS="rdepend"
-
-inherit distutils-r1
-
-DESCRIPTION="Google's Protocol Buffers - Python bindings"
-HOMEPAGE="https://developers.google.com/protocol-buffers/ https://github.com/protocolbuffers/protobuf"
-SRC_URI="https://github.com/protocolbuffers/protobuf/archive/v${PV}.tar.gz -> protobuf-${PV}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/22"
-KEYWORDS="~amd64"
-IUSE=""
-
-BDEPEND="${PYTHON_DEPS}
- ~dev-libs/protobuf-${PV}
- dev-python/namespace-google[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="${PYTHON_DEPS}
- ~dev-libs/protobuf-${PV}"
-RDEPEND="${BDEPEND}"
-
-S="${WORKDIR}/protobuf-${PV}/python"
-
-if [[ "${PV}" == "9999" ]]; then
- EGIT_CHECKOUT_DIR="${WORKDIR}/protobuf-${PV}"
-fi
-
-python_prepare_all() {
- pushd "${WORKDIR}/protobuf-${PV}" > /dev/null || die
- eapply "${FILESDIR}/${PN}-3.13.0-google.protobuf.pyext._message.PyUnknownFieldRef.patch"
- eapply_user
- popd > /dev/null || die
-
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- mydistutilsargs=(--cpp_implementation)
-}
-
-python_compile() {
- python_is_python3 || local -x CXXFLAGS="${CXXFLAGS} -fno-strict-aliasing"
- distutils-r1_python_compile
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- find "${ED}" -name "*.pth" -type f -delete || die
-}