aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyBigWig')
-rw-r--r--dev-python/pyBigWig/Manifest1
-rw-r--r--dev-python/pyBigWig/pyBigWig-0.3.17.ebuild7
-rw-r--r--dev-python/pyBigWig/pyBigWig-0.3.18.ebuild25
-rw-r--r--dev-python/pyBigWig/pyBigWig-9999.ebuild7
4 files changed, 34 insertions, 6 deletions
diff --git a/dev-python/pyBigWig/Manifest b/dev-python/pyBigWig/Manifest
index 96d66a343..b27a43a9b 100644
--- a/dev-python/pyBigWig/Manifest
+++ b/dev-python/pyBigWig/Manifest
@@ -1 +1,2 @@
DIST pyBigWig-0.3.17.tar.gz 65490 BLAKE2B 5ae3ad5792357ae36082022aa34548fb7ad105909eccc27305064f8f948714f462e1d239c3af7f9b75b84f5658bcb03231d7d1d3b0ebc8025c96d2e7835f1bfb SHA512 b52fec3a85984708660dd454f5569900a5cce7804d02e719bddbdc7ed2f9f4ab1131e55b0a01ae977b18bb0bbd079e13ec887d5df108d8abfebdd04ad56e503f
+DIST pyBigWig-0.3.18.tar.gz 66478 BLAKE2B 0d2e20bed5f59fb8c79026f453c4d5c3e4f9b663e96614b3ef8cbb939357c8895edfa92184da018efdd40e14bbf357f13cc32f898d9cf89419382e7be89b01c8 SHA512 e782f059a8c47043498b2c4b1c0b63f3a1863d03f641c469995536bded220714c61fe0a2f1dbe5841152fe54d0d43b544e14ec4999447d4d808e01b452fa5e88
diff --git a/dev-python/pyBigWig/pyBigWig-0.3.17.ebuild b/dev-python/pyBigWig/pyBigWig-0.3.17.ebuild
index eaa5d5375..acaca2306 100644
--- a/dev-python/pyBigWig/pyBigWig-0.3.17.ebuild
+++ b/dev-python/pyBigWig/pyBigWig-0.3.17.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1
DESCRIPTION="quick access to and creation of bigWig files"
diff --git a/dev-python/pyBigWig/pyBigWig-0.3.18.ebuild b/dev-python/pyBigWig/pyBigWig-0.3.18.ebuild
new file mode 100644
index 000000000..acaca2306
--- /dev/null
+++ b/dev-python/pyBigWig/pyBigWig-0.3.18.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="quick access to and creation of bigWig files"
+HOMEPAGE="https://github.com/dpryan79/pyBigWig"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/dpryan79/pyBigWig"
+else
+ SRC_URI="https://github.com/dpryan79/pyBigWig/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="sci-biology/libBigWig"
+RDEPEND="${DEPEND}"
diff --git a/dev-python/pyBigWig/pyBigWig-9999.ebuild b/dev-python/pyBigWig/pyBigWig-9999.ebuild
index eaa5d5375..acaca2306 100644
--- a/dev-python/pyBigWig/pyBigWig-9999.ebuild
+++ b/dev-python/pyBigWig/pyBigWig-9999.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1
DESCRIPTION="quick access to and creation of bigWig files"