aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyaml-env/pyaml-env-1.2.1.ebuild')
-rw-r--r--dev-python/pyaml-env/pyaml-env-1.2.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/pyaml-env/pyaml-env-1.2.1.ebuild b/dev-python/pyaml-env/pyaml-env-1.2.1.ebuild
new file mode 100644
index 000000000..a5169040a
--- /dev/null
+++ b/dev-python/pyaml-env/pyaml-env-1.2.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit pypi distutils-r1
+
+DESCRIPTION="Parse YAML configuration with environment variables in Python"
+HOMEPAGE="https://pypi.org/project/pyaml-env/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~amd64-linux"
+
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+
+# tests not included in pypi tarball
+RESTRICT="test"
+#distutils_enable_tests pytest