aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pydotplus')
-rw-r--r--dev-python/pydotplus/Manifest1
-rw-r--r--dev-python/pydotplus/metadata.xml19
-rw-r--r--dev-python/pydotplus/pydotplus-2.0.2.ebuild31
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/pydotplus/Manifest b/dev-python/pydotplus/Manifest
new file mode 100644
index 000000000..ba1c33a4b
--- /dev/null
+++ b/dev-python/pydotplus/Manifest
@@ -0,0 +1 @@
+DIST pydotplus-2.0.2.tar.gz 278677 SHA256 91e85e9ee9b85d2391ead7d635e3d9c7f5f44fd60a60e59b13e2403fa66505c4 SHA512 6f06a1f284401123a4514f9e9a4974dee8dc8d01e6b7c40a797fb70eed22b99fe774272f8b106b5632a33f524b356349fe1ff9633101ff61ef2fc3fe69d641ac WHIRLPOOL 5f0662c5f02a0e57ea7480ca3bbbc43d23b9690680bd37fcfe58645476656aee9d4336a5e77643ad2f34da0b5b97483ae012f24378e2642dc21887756110fa17
diff --git a/dev-python/pydotplus/metadata.xml b/dev-python/pydotplus/metadata.xml
new file mode 100644
index 000000000..6efcdec57
--- /dev/null
+++ b/dev-python/pydotplus/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>h.chr@mail.ru</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ PyDotPlus is an improved version of the old pydot project that provides a Python Interface to
+ Graphviz’s Dot language.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">pydotplus</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pydotplus/pydotplus-2.0.2.ebuild b/dev-python/pydotplus/pydotplus-2.0.2.ebuild
new file mode 100644
index 000000000..33dae9837
--- /dev/null
+++ b/dev-python/pydotplus/pydotplus-2.0.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Improved version of the old pydot project"
+HOMEPAGE="http://pydotplus.readthedocs.org/"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "
+RDEPEND="
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ "
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_test() {
+ ${PYTHON} -m unittest discover
+}