aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pygsl/pygsl-0.9.0.ebuild')
-rw-r--r--dev-python/pygsl/pygsl-0.9.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pygsl/pygsl-0.9.0.ebuild b/dev-python/pygsl/pygsl-0.9.0.ebuild
new file mode 100644
index 000000000..d2448ee1a
--- /dev/null
+++ b/dev-python/pygsl/pygsl-0.9.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit distutils
+
+DESCRIPTION="A Python interface for the GNU scientific library (gsl)."
+HOMEPAGE="http://pygsl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND=">=sci-libs/gsl-1.8
+ >=dev-python/numpy-1.0"
+
+
+src_test() {
+ cd "${S}/tests"
+ PYTHONPATH=../build/lib* "${python}" run_test.py || die "tests failed"
+}
+
+src_install() {
+ distutils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}