aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pynwb')
-rw-r--r--dev-python/pynwb/Manifest2
-rw-r--r--dev-python/pynwb/metadata.xml24
-rw-r--r--dev-python/pynwb/pynwb-2.5.0.ebuild50
-rw-r--r--dev-python/pynwb/pynwb-2.6.0.ebuild51
4 files changed, 127 insertions, 0 deletions
diff --git a/dev-python/pynwb/Manifest b/dev-python/pynwb/Manifest
new file mode 100644
index 000000000..0dffbb9ab
--- /dev/null
+++ b/dev-python/pynwb/Manifest
@@ -0,0 +1,2 @@
+DIST pynwb-2.5.0.tar.gz 620770 BLAKE2B 470f5127560bf79f112061e9e8af208051d76833e449a66b03e31bb0828ffbfd6aa0b9efc136ecc0b7efba758334c3f15525a41ec4540c6f55d02f8afbd55ab2 SHA512 cad84e3ac6c3c67c3c28e3c3ec44402bfc94c4cf988fbe64ddfa461a67115398b24bb9bcac1bd00933e1b63d73048d9b20ec6cd736a51d9f2c7bf4d294edb261
+DIST pynwb-2.6.0.tar.gz 625188 BLAKE2B ac179af7e3c9de6ec4fb841dfd6279a1c3ba191b9d786553af02397a49c511f4a257a0e62f3b57a217ebb08588ad8ca64219fd435b3ec25776775d05e6a9ab9b SHA512 5c830cb37e8c6fe0643bd5bfee947565ddb1d0eff16dadadd3ebec7ec14a6e1ebcf34c3909ad05c3eedd8dd5f9e3669348216d695123f2013de0e969a403ec1c
diff --git a/dev-python/pynwb/metadata.xml b/dev-python/pynwb/metadata.xml
new file mode 100644
index 000000000..1e30097b2
--- /dev/null
+++ b/dev-python/pynwb/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@chymera.eu</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ PyNWB is a Python package for working with NWB files. It provides a
+ high-level API for efficiently working with Neurodata stored in the NWB
+ format. Neurodata Without Borders: Neurophysiology (NWB:N) is a project
+ to develop a unified data format for cellular-based neurophysiology
+ data, focused on the dynamics of groups of neurons measured under a
+ large range of experimental conditions.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">pynwb</remote-id>
+ <remote-id type="github">NeurodataWithoutBorders/pynwb</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pynwb/pynwb-2.5.0.ebuild b/dev-python/pynwb/pynwb-2.5.0.ebuild
new file mode 100644
index 000000000..ca11c3dbe
--- /dev/null
+++ b/dev-python/pynwb/pynwb-2.5.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python API for working with Neurodata stored in the NWB Format "
+HOMEPAGE="https://github.com/NeurodataWithoutBorders/pynwb"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/hdmf-3.3.2[${PYTHON_USEDEP}]
+ >=sci-libs/hdf5-1.12.2
+ dev-python/h5py[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ "
+
+EPYTEST_DESELECT=(
+ # Reported upsream:
+ # https://github.com/NeurodataWithoutBorders/pynwb/issues/1580
+ tests/validation/test_validate.py::TestValidateCLI::test_validate_file_cached
+ tests/validation/test_validate.py::TestValidateCLI::test_validate_file_cached_bad_ns
+ tests/validation/test_validate.py::TestValidateCLI::test_validate_file_cached_core
+ tests/validation/test_validate.py::TestValidateCLI::test_validate_file_cached_extension
+ tests/validation/test_validate.py::TestValidateCLI::test_validate_file_cached_extension_pass_ns
+ tests/validation/test_validate.py::TestValidateCLI::test_validate_file_cached_hdmf_common
+ tests/validation/test_validate.py::TestValidateCLI::test_validate_file_cached_ignore
+ tests/validation/test_validate.py::TestValidateCLI::test_validate_file_invalid
+ tests/validation/test_validate.py::TestValidateCLI::test_validate_file_list_namespaces_core
+ tests/validation/test_validate.py::TestValidateCLI::test_validate_file_list_namespaces_extension
+ tests/validation/test_validate.py::TestValidateCLI::test_validate_file_no_cache
+ tests/validation/test_validate.py::TestValidateCLI::test_validate_file_no_cache_bad_ns
+ # Reported upstream:
+ # https://github.com/NeurodataWithoutBorders/pynwb/issues/1800
+ tests/unit/test_file.py::TestNoCacheSpec::test_simple
+ # Not sandboxed, reported upstream:
+ # https://github.com/NeurodataWithoutBorders/pynwb/issues/1800
+ tests/read_dandi/test_read_dandi.py::TestReadNWBDandisets::test_read_first_nwb_asset
+)
+
+distutils_enable_tests pytest
diff --git a/dev-python/pynwb/pynwb-2.6.0.ebuild b/dev-python/pynwb/pynwb-2.6.0.ebuild
new file mode 100644
index 000000000..2f403981c
--- /dev/null
+++ b/dev-python/pynwb/pynwb-2.6.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python API for working with Neurodata stored in the NWB Format "
+HOMEPAGE="https://github.com/NeurodataWithoutBorders/pynwb"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/hdmf-3.3.2[${PYTHON_USEDEP}]
+ >=sci-libs/hdf5-1.12.2
+ dev-python/h5py[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ "
+
+EPYTEST_DESELECT=(
+ # Reported upsream:
+ # https://github.com/NeurodataWithoutBorders/pynwb/issues/1580
+ tests/validation/test_validate.py::TestValidateCLI::test_validate_file_cached
+ tests/validation/test_validate.py::TestValidateCLI::test_validate_file_cached_bad_ns
+ tests/validation/test_validate.py::TestValidateCLI::test_validate_file_cached_core
+ tests/validation/test_validate.py::TestValidateCLI::test_validate_file_cached_extension
+ tests/validation/test_validate.py::TestValidateCLI::test_validate_file_cached_extension_pass_ns
+ tests/validation/test_validate.py::TestValidateCLI::test_validate_file_cached_hdmf_common
+ tests/validation/test_validate.py::TestValidateCLI::test_validate_file_cached_ignore
+ tests/validation/test_validate.py::TestValidateCLI::test_validate_file_invalid
+ tests/validation/test_validate.py::TestValidateCLI::test_validate_file_list_namespaces_core
+ tests/validation/test_validate.py::TestValidateCLI::test_validate_file_list_namespaces_extension
+ tests/validation/test_validate.py::TestValidateCLI::test_validate_file_no_cache
+ tests/validation/test_validate.py::TestValidateCLI::test_validate_file_no_cache_bad_ns
+ # Reported upstream:
+ # https://github.com/NeurodataWithoutBorders/pynwb/issues/1800
+ tests/unit/test_file.py::TestNoCacheSpec::test_simple
+ # Not sandboxed, reported upstream:
+ # https://github.com/NeurodataWithoutBorders/pynwb/issues/1800
+ tests/read_dandi/test_read_dandi.py::TestReadNWBDandisets::test_read_first_nwb_asset
+ tests/unit/test_base.py::TestTimeSeries::test_repr_html
+)
+
+distutils_enable_tests pytest