aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyout/pyout-0.7.3.ebuild')
-rw-r--r--dev-python/pyout/pyout-0.7.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pyout/pyout-0.7.3.ebuild b/dev-python/pyout/pyout-0.7.3.ebuild
new file mode 100644
index 000000000..7246139ee
--- /dev/null
+++ b/dev-python/pyout/pyout-0.7.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="Terminal styling for structured data"
+HOMEPAGE="https://github.com/pyout/pyout"
+#SRC_URI="https://github.com/pyout/pyout/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/blessed[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+#PATCHES=( "${FILESDIR}/${PN}-0.7.2-blessed.patch" )
+
+python_prepare_all() {
+ sed -i -e '/pytest-runner/d' setup.py || die
+ distutils-r1_python_prepare_all
+}